MySQL & Grafana 8: "results value" shown as legend. Bug?

  • What Grafana version and what operating system are you using?
  • v8.0.2
  • What are you trying to achieve?
    After upgrade from v7 within a Graph (Old) panel with two queries (one from MySQL and anohter from InfluxDB) suddenly “results value” is shown in the metric name.

Disabling/removing the influxDB query makes "results " disapear but “value” stays. Renaming the column to “” in MySQL query makes “value” disapear. Is that really intended behaviour? It seem it doesn’t according to the MySQL Grafana documentation.

  • How are you trying to achieve it?
    The querys using do not have an affect on this. But anyhow here examples:
  env AS metric,
  count(id) AS value
FROM captures
ORDER BY $__timeGroup(runAt,$__interval)

The Influx query
SELECT mean("PercentProcessingUnitUsed") FROM "systemStatus" WHERE ("host" = 'MyServer') AND $timeFilter GROUP BY time($__interval) fill(linear)

  • What did you expect to happen?
    Not showing results nor value as metric name.

  • Did you receive any errors in the Grafana UI or in related logs?

  • Did you follow any online instructions? If so, what is the URL?
    mysql documentation


Got the exactly same bug & behavior in Version v8.0.6 (68fe9e3431). The Bug appears with the old Panel as well as with the new timeseries one. Same query in Single Source Dashboard (only MySQL query`s no mixed sources) is working perfect.

SQL Query:

  TimeStamp AS "time",
  Pac1 AS "Phase 1 PV"
FROM SpotData
ORDER BY TimeStamp


I’m experiencing the same Bug with PostgreSQL. Grafana v8.0.6.

After an upgrade to grafana 8.1.5, we are experience the same problem on PostgreSQL graphs. No changes were made to graph and everything was working in grafana version 7.

As a temporary workaround, you can set the “Display Name” attribute (left config panel, under standard options) as ${__field.labels.you_label_name} taken from the docs Standard field options | Grafana Labs

This topic was automatically closed after 365 days. New replies are no longer allowed.