500 Limit when using Elasticsearch Datasource

My goal is to “Group By” a certain field in Grafana. I query 1000s of documents from Elasticsearch (I know the 10k limit from ES), but in Grafana only 500 rows get displayed.
I set the size parameter to “No limit” but limit is still at 500.

Is there a trick to overcome the 500 limit in Grafana?
I’m using “Grafana v10.1.4 (a676a96d91)”

Thanks for any help.

I was having the same problem.
The solution is to manually add the number of lines.
Obs:

“No limit”
Default = 500

ajuste_noLimite