ES index.mapping.total_fields.limit in Grafana

Hi,
I am NOT able to load the Elastic search index( enabled with dynamic mapping) , which has 2000+ fields in Grafana. The Elastic index settings is
“index.write.wait_for_active_shards”: “1”,
“index.mapping.nested_fields.limit”: “500”,
“index.mapping.nested_objects.limit”: “100000”,
“index.mapping.total_fields.limit”: “10000”,

  1. Is there a limit in Grafana wrt ES default limits - we cannot go beyond 500 fields ?
    Mapping limit settings | Elasticsearch Guide [master] | Elastic
  2. Is there a way to change the Grafana setting ?

Any help would be appreciated
Thanks
Dhivya