Tables and Datalinks Broken in Upgrade from 7.3.1 to 7.5.3

I upgraded our Grafana environment this morning, and at first, I thought everything was great.

But then we found this bug. All of our dashboards using table panels with datalinks on fields within rows of the table broke.

Visually, you could tell something was wrong because the underscore that indicated there was a link was missing. However, you could still click on the field, and the new browser tab with the drill down dashboard would open up.

However, this is were the worse bug occurred. The data that appears in the new dashboard didn’t match the data the was clicked on. It was for a different set of criteria belonging to another row.

After some debugging, I discovered that the problem has to do with panel level sorting and filtering. If I did all the sorting in the query (in this case, Flux against InfluxDB), the data link contains data from the matching row. However, if you clicked on the table header to resort the dashboard, the rows in the panel would reorder, but the URL’s associated with that data still contained values related to the row that was in that position before the sort. Also, if you turned on filtering and filtered, the same problem occurred. If you filtered to only one row in the table, the data in the URL still matched whatever data was present in the first row of the data before the filter.

This all worked fine in 7.3.1.

I tried creating a new dashboard with a new panel to see if the bug was related to upgrading from a 7.3.1 version of the table panel to a 7.5.3 version. But that didn’t help. The problem still occurred with a brand new panel.

I’m wondering if this has something to do with the dashboard caching I read was introduced with 7.5. Is there a setting somewhere to turn that off? I want t see if that solves my problem.

Has this already been reported? Anyone got a work around? Googling didn’t turn up any hits.

Thanks,
Kevin

Hello and welcome to the forums. can you try to flush all data and redo the upgrade again? best regards

Thanks for the reply.

What do you mean by “flush all data”? Got a link that walks me through what you’re referring to?

no sorry, by flush i mean wipe out

What do you want me to wipe out? I definitely don’t want to have to recreate all of my dashboards. Which files/directories are you wanting me to delete?

I should add, I’m running on RHEL 8.

Fix is included in Grafana 7.5.4 release

1 Like

Thanks! I will pass on the good news to our users.

related PR:

So I just upgraded our 7.5.3 to 7.5.4 in development.

The goods news is that the URL’s now load the correct data from the row once sorting or filtering is done.

The bad news is that the underline indicating that the value is a URL is still missing. I haven’t looked around yet, but is there an option to turn that on and off or is that really broken?

Regardless, the URL value fix is a big improvement and the formatting is by far the lesser of wo problems.

Thanks again,
Kevin

Hi @kvntylr,

Good catch, Kevin. I tested this and you’re right. I think this should get fixed, as it is an accessibility concern. I can make an issue for this and tag you on GitHub, if you like.

~matt

That would be great. Thanks!

Kevin

you have a GH profile?

Something like this would may do the trick:

.css-12b6ioh > div > div {
text-decoration: underline;
}

But i have no clue how to inject this into the mass of oneliners.

here’s some progress on this fix: