Problems with Data Links in Grafana 9.5.1 - Docker


After upgrade Grafana from 9.4.7 version to 9.5.1 version, all the data links that I have in a dashboard, in a Table Panel, now have at the beginning the URL of Grafana + the original URL of Data Link.

For example, before upgrade, the data link points to:
After the upgrade, the data link points to:

Even trying to delete and recreate the Data Links, the problem persists.

I’m obtaining the URL of Data Link from an internal Grafana variable. Sometimes from the value of the same field that I’m configuring for Data Link, ${__value.raw}, and sometimes from another field that I’m hiding in the table, ${__data.fields[url]}.

I tried Data Links without upgrade, in a fresh Grafana 9.5.1 docker installation, and the problem exists too.

EDIT: It is only happening when I use a Grafana variable as part of the value of the Data Link. If I fill the Data Link with some static URL, like, it works ok. For example, for the next screenshot, the first two entries are not working, and the third entry is working ok:

EDIT2: I can confirm that the same is happening on Grafana Play, which is on version 9.5.x too:

Anybody with the same problem?

Thanks in advance.

1 Like

I can confirm this same problem on the same version, also in docker. All links that are using ${__value.raw} for Data Link have the value of GF_SERVER_ROOT_URL attached to them.

Same over here.

I use the following field: ${__data.fields.install_url}.
install_url comes from the database (query).

The result is https://<>/

Wondering whether the % encoded values are OK, for the browser.
I tested it in an simple http page, and the browser is not happy with them…
%3A = :
%2F = /

I hope this can be fixed, quickly.

I fixed it by using the format option “:raw” for the problematic urls.
Not sure if that’s the desired situation.

It looks like that the datalinks are now use :percentcode as the default format option.

1 Like

Thanks @radoeka!

The “:raw” option in the variables that I’m using do the trick for me.

Really thanks for your help.