Sqlite datasource not expected responses


  • What Grafana version and what operating system are you using?
    I’m using grafana 7.5, frser-sqlite-datasource plugin as datasource on windows.

  • What are you trying to achieve?
    when i used this same plugin on grafana 8.4, it worked welll

  • How are you trying to achieve it?
    reach same result in grafana 7.5 as in 8.4

  • What happened?
    i’m receiving this strange response on

  • What did you expect to happen?
    considering that i’m using ae3e-plotly-panel to contruct the graphs
    in grafana version 8.4, the data logs:

    with data working as i want, but in 7.5:

    i can find the data here, but only when i’m leading with floats and int
    when the data is a string i’m receiving strange arrays with random number like this:

Any reason you are still using 7.5 if things work in 8?

I remember that the datatypes did look different in the types in the internal Grafana communication.

So just “weird strings in the API” does not mean anything bad necessarily. Is there a panel that does not display correctly in the version 7? Because even with the “strange data” all standard panels work, no?