RPI3B+ doesn't render/draw the graphs


I am trying to replace a ASUS ChromeBit which we used to show our Grafana graphs (a playlist of multiple dashboards).
But I can’t get it to draw the graphs in Chromium.
I am currently running Raspbian Stretch with X.

Does anyone know a fix for this?
Is it because the JS behind the dashboards are too heavy for a Raspberry PI 3B+ ?

The specs of the RPI3B+ is:

  • Broadcom BCM2837B0, Cortex-A53 (ARMv8) 64-bit SoC @ 1.4GHz

Rendering might be slow on Raspberry PI if you have a lot of graphs/re-render quite often, but it should definitely work.

Are there any errors in your log file? check /var/log/grafana/
Or in the Chromium developer console?

How did you install Grafana?

It doesn’t render at ALL.
It do come up with some jquery stuff in the console in Chromium.

Grafana is hosted elsewhere i’m just opening the GUI on the raspberry pi.

Ah. Are there any errors in the chromium dev console? and if so, could you copy them or take a screenshot?

It’s saying:
Uncaught TypeError: Cannot read property ‘save’ of null
at J (jquery.flat.js.3048)

I have set the Raspberry PI GPU memory to 256.

side note:
We run Grafana v5.3.1 (08c7908)

Not sure what would cause that but will ask if any of my colleagues have experience with similar problems. I presume you have tried running chromium with default settings as well? (128mb of GPU RAM)

Yes, default settings for GPU memory is 64, i have tried all settings for that.
I have even tried forcing chromium to use EGL.

I have also tried Firefox, we are currently showing our dashboards on a Chromebit which works perfectly but they have died so easily so thats why we are researching the market for other display options that can show Grafana and so on.

We have ordered other single boarded machines that is more powerful than a RASP PI 3B+

I have used Raspberry Pi 2B+ devices to with Grafana in the past so I’d be really surprised if it wasn’t possible to get it working with the 3rd gen. Just as a reference, have you tried going to play.grafana.org with the Pi?

I’ve just tested it out and it doesn’t render.
I have tried with 64MB and 128MB gpu memory.

Btw, is there anything in the Chromium application log?

don’t exactly know where those are.
But, i have just looked in “about:gpu” and it’s actually a little interesting.

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
CheckerImaging: Disabled
Flash: Unavailable
Flash Stage3D: Unavailable
Flash Stage3D Baseline profile: Unavailable
Compositing: Software only. Hardware acceleration disabled
Multiple Raster Threads: Enabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Rasterization: Unavailable
Video Decode: Unavailable
WebGL: Hardware accelerated but at reduced performance
WebGL2: Unavailable
Driver Bug Workarounds
Problems Detected
Accelerated video decode is unavailable on Linux: 137247
Disabled Features: accelerated_video_decode
Only enable WebGL for the Mesa Gallium llvmpipe driver: 571899
Disabled Features: flash_stage3d, gpu_compositing, gpu_rasterization, flash3d, accelerated_webgl2, accelerated_2d_canvas, accelerated_video_decode, flash_stage3d_baseline
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Mesa drivers in Linux handle varyings without static use incorrectly: 333885
Applied Workarounds: count_all_in_varyings_packing
Always rewrite vec/mat constructors to be consistent: 398694
Applied Workarounds: scalarize_vec_and_mat_constructor_args
Use GL_INTEL_framebuffer_CMAA on ChromeOS: 535198
Applied Workarounds: disable_framebuffer_cmaa
Disable partial swaps on Mesa drivers (detected with GL_VERSION): 339493
Applied Workarounds: disable_post_sub_buffers_for_onscreen_surfaces
Decode and encode before generateMipmap for srgb format textures on os except macosx: 634519
Applied Workarounds: decode_encode_srgb_for_generatemipmap
Disable KHR_blend_equation_advanced until cc shaders are updated: 661715
Applied Workarounds: disable(GL_KHR_blend_equation_advanced), disable(GL_KHR_blend_equation_advanced_coherent)
Don't expose disjoint_timer_query extensions to WebGL: 808744
Gpu compositing has been disabled, either via blacklist, about:flags or the command line. The browser will fall back to software compositing and hardware acceleration will be unavailable.
Disabled Features: gpu_compositing
Native GpuMemoryBuffers have been disabled, either via about:flags or command line.
Disabled Features: native_gpu_memory_buffers
Checker-imaging has been disabled via finch trial or the command line.
Disabled Features: checker_imaging
Version Information
Data exported	2018-10-09T18:43:21.051Z
Chrome version	Chrome/65.0.3325.181
Operating system	Linux 4.14.71-v7+
Software rendering list URL	https://chromium.googlesource.com/chromium/src/+/abb5172872b726072a64dfabaf45894c6ecf7369/gpu/config/software_rendering_list.json
Driver bug list URL	https://chromium.googlesource.com/chromium/src/+/abb5172872b726072a64dfabaf45894c6ecf7369/gpu/config/gpu_driver_bug_list.json
ANGLE commit id	unknown hash
2D graphics backend	Skia/65 8a3e0b31927ae78bc3e9c342b1290a6a64233674-
Command Line	/usr/lib/chromium-browser/chromium-browser --disable-quic --enable-tcp-fast-open --disable-gpu-compositing --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args=enable_stagevideo_auto=0 --ppapi-flash-version= --enable-pinch --flag-switches-begin --flag-switches-end
Driver Information
Initialization time	1010
In-process GPU	false
Passthrough Command Decoder	false
Direct Composition	false
Supports overlays	false
Sandboxed	false
GPU0	VENDOR = 0x0000, DEVICE= 0x0000 *ACTIVE*
Optimus	false
Optimus	false
AMD switchable	false
Driver vendor	Mesa
Driver version	13.0.6
Driver date	
Pixel shader version	1.30
Vertex shader version	1.30
Max. MSAA samples	0
Machine model name	
Machine model version	
GL_VENDOR	VMware, Inc.
GL_RENDERER	Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)
GL_VERSION	3.0 Mesa 13.0.6
GL_EXTENSIONS	GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_stencil_export GL_AMD_shader_trinary_minmax GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_conditional_render_inverted GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_robustness GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_objects GL_ARB_shader_stencil_export GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_window_pos GL_ATI_blend_equation_separate GL_ATI_draw_buffers GL_ATI_fragment_shader GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_texture GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_KHR_context_flush_control GL_KHR_debug GL_MESA_pack_invert GL_MESA_shader_integer_functions GL_MESA_texture_signed_rgba GL_MESA_window_pos GL_MESA_ycbcr_texture GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_primitive_restart GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_OES_EGL_image GL_OES_read_format GL_S3_s3tc GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays
Disabled Extensions	GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent
Disabled WebGL Extensions	EXT_disjoint_timer_query EXT_disjoint_timer_query_webgl2
Window system binding vendor	SGI
Window system binding version	1.4
Window system binding extensions	GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_multisample GLX_EXT_create_context_es_profile GLX_EXT_create_context_es2_profile GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_import_context GLX_EXT_libglvnd GLX_EXT_texture_from_pixmap GLX_EXT_visual_info GLX_EXT_visual_rating GLX_MESA_copy_sub_buffer GLX_OML_swap_method GLX_SGI_make_current_read GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group
Window manager	Openbox
GDMSESSION	lightdm-xsession
Compositing manager	No
Direct rendering	Yes
Reset notification strategy	0x8261
GPU process crash count	0
System visual ID	33
RGBA visual ID	65
Compositor Information
Tile Update Mode	One-copy
Partial Raster	Enabled
GpuMemoryBuffers Status
ATC	Software only
ATCIA	Software only
DXT1	Software only
DXT5	Software only
ETC1	Software only
R_8	Software only
R_16	Software only
RG_88	Software only
BGR_565	Software only
RGBA_4444	Software only
RGBX_8888	Software only
RGBA_8888	Software only
BGRX_8888	Software only
BGRX_1010102	Software only
BGRA_8888	Software only
RGBA_F16	Software only
YVU_420	Software only
YUV_420_BIPLANAR	Software only
UYVY_422	Software only
Display(s) Information
Info	Display[0] bounds=0,0 1920x1080, workarea=0,0 1920x1080, scale=1, external
Color space information	{primaries:INVALID, transfer:INVALID, matrix:INVALID, range:INVALID}
Bits per color component	8
Bits per pixel	24
Video Acceleration Information
Log Messages
[924:924:1009/202000.566883:ERROR:sandbox_linux.cc(375)] : InitializeSandbox() called with multiple threads in process gpu-process.

Nothing in there that jumps out at me. You could try starting Chromium from the terminal and see if there are any errors in the terminal if you go to Grafana to view your graphs.

I have tried running chromium with:
chromium-browser --ignore-gpu-blacklist --enable-gpu-rasterization --enable-native-gpu-memory-buffers --enable-checker-imaging --disable-quic --enable-tcp-fast-open --disable-gpu-compositing --enable-fast-unload --enable-experimental-canvas-features --enable-scroll-prediction --enable-simple-cache-backend --answers-in-suggest --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args=enable_stagevideo_auto=0 --ppapi-flash-version= --max-tiles-for-interest-area=512 --num-raster-threads=4 --default-tile-height=512

no specifics errors in console.
All settings in about:gpu is now hardware accelerated, and it still doesn’t render.

I guess let’s wait for your colleagues to return back :slight_smile: I am also open for trying another OS than Raspbian Stretch.

I’ve chatted with some of my colleagues but no one has had any good ideas so far. I’m actually getting a new raspberry pi 3b+ myself soon so if I find the time I might just test it out myself.

Thanks. i will wait for that then :slight_smile:

1 Like

I have the same setup working - on a pi2 and pi3, this is all I had to do to make it work:

~/.config/lxsession/LXDE-pi $ cat autostart
@lxpanel --profile LXDE
@pcmanfm --desktop --profile LXDE-pi
@point-rpi # new for stretch
@xdg-settings set default-web-browser chromium-browser.desktop
@xset s off
@xset -dpms
@xset s noblank
@unclutter -display :0.0 -idle 5
@chromium-browser --noerrdialogs --kiosk https://bkgann2.grafana.net --incognito --no-first-run

here’s the uname and os-release data:

pi@seshat:~/.config/lxsession/LXDE-pi $ uname -a
Linux seshat 4.14.71-v7+ #1145 SMP Fri Sep 21 15:38:35 BST 2018 armv7l GNU/Linux
pi@seshat:~/.config/lxsession/LXDE-pi $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION="9 (stretch)"

for chromium it’s the default install, with current updates:

pi@seshat:~/.config/lxsession/LXDE-pi $ dpkg -l | grep chromium
ii  chromium-browser                      65.0.3325.181-0+rpt4              armhf        Chromium web browser, open-source version of Chrome
ii  chromium-browser-l10n                 65.0.3325.181-0+rpt4              all          chromium-browser language packages
ii  chromium-codecs-ffmpeg-extra          65.0.3325.181-0+rpt4              armhf        Extra ffmpeg codecs for the Chromium Browser
ii  rpi-chromium-mods                     20181008                          armhf        Raspberry Pi-specific mods to Chromium

I’d suggest trying @bkgann’s setup and if that doesn’t work I’d try reinstalling Raspbian. I booted up a freshly installed Raspbian on a 3B+ this just now and it rendered Grarfana graphs (from http://play.grafana.org/) without a hitch. My guess would be that it’s either something specific to your install or your Raspberry.

Hi guys,

Thanks for the reply @bkgann i tried your settings, doesn’t render the playground.
I have probably messed something up with the settings on rasbian it self.

I even tried to remove my POE HAT i had on, i have read it uses some performance on USB and so on, no luck.


I have the exact same issue only graph impacted.
I see my system was not at the correct date.
I’ve update the date and now i can display graph.