Grafana cloud login fails with Chromium browser

Hi,

I’ve ran Chromium as a sort of kiosk browser mode in my garage to display a dashboard in raspberry-pi + monitor combination.

Today it stopped working after I updated the Grafana dashboard with my Macbook Chrome and saved it, after which login in the Chromium browser rpi fails.

This is what happens and how to replicate it:

  • I cleared all the cookies/cache from the Chromium browser in my rpi
  • Start Chromium and navigate to my dashboard (nilsbo.grafana.net)
  • Get grafana login screen
  • Authenticate
  • Then everything seems to go normal, I get the screen below
  • And after a few seconds I’m logged out and redirected back to grafana cloud login

I can open the dashboard without any issues from other browsers, such as my macbook and Chrome, but the kiosk rpi running raspbian and chromium is not able to log in.

Any suggestions?

And thanks for the great, great product!

We’re experiencing almost the same issue with our local Grafana installation.
After (successfully) logging in the loginscreen appears again (Chromium and Firefox on Rpi3B)

Google Chrome browser (Win10) is working fine…

Same issue here after upgrading to Grafana 7.0 and trying to log in on my Raspberry Pi 3/ Chromium. After the green notification of “Login Success” appears but getting redirected to the login screen again. Works on all other machines.

Tried the settings suggested here

[security]
cookie_secure = true
cookie_samesite = none

but it seems not to have helped.

The following on the rpi fixed this for me -

apt install chromium-browser

1 Like

Just in case someone has the same problem. We have two raspberry pi boards.
Same hardware, they are raspberry pi3, but setup different period of time.
So one using rasbian jessie, another one use stretch. After upgrade grafana
to 7.0 recently. Chromium 56.0.2924.84-0ubuntu0.14.04.1.1000 on jessie has strange behaviour. I can login, but after a few seconds was kickout to login screen once again. Search internet and found this page. change [security] cookie_samesite = none not help.
But chromium 72.0.3626.121-0+rpt4 on another system just work fine.
So, I think, it might be a good time to upgrade raspbian to the latest version, if that’s possible. :slight_smile: