Chromium browser errors after upgrading to version 10.2.2 or later

Hello.

We were unable to display our Grafana dashboards after updating to a version higher than version 10.2.2.

The equipment we use to display the dashborads are our ASUS TINKERS that run DEBIAN 10.9 (32-bit) with Chromium 90.0.4430.212 browser.

We are unable to open any more dashboards or even the grafana screens, after logging in it lands on this screen:

If you’re seeing this Grafana has failed to load its application files

  1. This could be caused by your reverse proxy settings.

  2. If you host grafana under subpath make sure your grafana.ini root_url setting includes subpath. If not using a reverse proxy make sure to set serve_from_sub_path to true.

  3. If you have a local dev build make sure you build frontend using: yarn start, or yarn build

  4. Sometimes restarting grafana-server can help

  5. Check if you are using a non-supported browser. For more information, refer to the list of supported browsers.

I’ve already done several tests, clearing the cache, opening an anonymous tab, but nothing worked!

I tested it on Firefox and it worked there, but on this system, Firebox is very heavy, consumes a lot of memory, making it unfeasible to use.

Well, Debian 10 went End-of Life in September 2022 (so 2½ years ago) and
although it has Long-Term Support for another 5 months from now, I believe
that’s basically only security fixes, not application updates.

https://wiki.debian.org/DebianReleases

Chromium 90.0.4430.212 dates from May 2021, and the current version is 121, so
this is also distinctly out of date.

https://chromiumdash.appspot.com/releases?platform=Linux

So, unless you are able to upgrade either the O/S or the Chromium package on
these Tinker boards (which I presume is possible, much the same as doing it on
a Raspberry?) then the version of browser you are using will inevitably
restrict the version of Grafana you can connect to.

Antony.

Unfortunately for the device, an Asus Tinker Board S, there are no further updates.

But in my understanding this is an implication without coherence from Grafana, because after the update, the dashboards continue to work for a few minutes, and only then does this alert start to appear and the display blocks, that is, there is no problem with the dashboard in this case. browser version, it is Grafana that checks the version and blocks it, but there is no problem!

The funny thing is that in Firefox, which is less updated and consumes more memory and crashes, it allows access, but Firefox doesn’t load the dashboards properly and however Grafana doesn’t block it!