Can't login after upgrading to v7.0

After upgrading to v7.0 we are unable to login to grafana. At the login screen, after typing in a the username and password, a green banner will pop up which states “Logged In”, but the webpage will refresh and be stuck at the login page.

Did you ever find a solution to this? I am having the same issue…we have about a dozen users, most are able to login fine, but two cannot. Tried different browsers, new user accounts, disabling some of the security features in the Grafana config, but nothing seems to be working for these two users. From the Grafana logs, it shows they are logged in fine, but then it just 302s back to the login page…never sets the uname, userId, orgId…but no errors logged, not reason why these aren’t set.

Hello,

This is a known issue on old versions of Edge and some TV browsers, you can find more discussion about this here: https://github.com/grafana/grafana/issues/25507

Are you sure your two users that can’t login are not on an old version of Edge? (before 44)

I am aware of the issue with Edge, as I said in my previous post the issue occurs on multiple browsers – we’ve tried Edge, Chrome, and even IE, and are getting the same issue with all three.

Checked what cookies are getting created…when they login they get a redirect_to cookie with a value of %2F (/), but not a grafana_session cookie…but when I login to grafana admin I do see their IP/browser in the list of active sessions. Have also checked the network logs in Chrome web tools and find no “Cookie:” header being returned by the server for the affected users.

Update:
I wrote a simple logging proxy and inserted that in front of Grafana to capture a few successful and failed login attempts. I do see the grafana_session cookie returned by the server there, but for some reason with these users when their system responds it is sending back the redirect_to cookie and not the grafana_session cookie. Otherwise I see no difference in the logs except the browser version (does Chrome 67 have the same issue as Edge?)

I also tried downgrading to Grafana 6.7.4 and still have the same issue there…last known working version is 5.3.4