Record on line 5: wrong number of fields

Hi, I am stuck with this problem on grafana,
actually Grafana v10.2.2 running on docker and well shows graph by flux,
I would try to add a Data source : a file .csv.

the file is provided by a link like: http://192.168.xxx.xxx:PPPP/share.cgi?ssid=somethingoforiginalhere
and grafana page tell me a “Success” (!)

But even the file is simple as possible I got only :
Record on line 5: wrong number of fields

I cannot see the raw table itself, no data, no graph.

Is it a generic error ? It persist even changing the file.

Any idea?
Thank you

if you have a csv file similar to this:

1,2,3,4,5,
1,2,3,4,5,
1,2, ,4, ,
, , , , ,
1,2,3,4,

Line 5 has one less field than the rest of the lines, you will get that error

1 Like

Thank your for thre reply !
Yes, the file was in that format I tried also :slight_smile:
variable_1,variable_2
1,2
3,4
BUT I solved:
the link set in grafana is a link that open a webpage where the user can click to download the file.
I discover later this, “SUCCESS” for grafana is almost reading a file, not parsing it. (this will be done later)
Anyway : I will remember to CHECK the link : it must be a direct url to a file not to a dinamic page.

Thank you anyway.