Grafana Time Series: Data is Missing a Number Field

  • What Grafana version and what operating system are you using?

I am using Grafana version 10.0.3 on Linux (Ubuntu, to be exact). I have the CSV Plugin for Grafana installed.

  • What are you trying to achieve?

I am trying to use Grafana’s time series visualization tool to plot a time series graph from a local CSV file.

  • How are you trying to achieve it?

I created a CSV datasource and specified the local file path and name. Then, I created a dashboard and selected the CSV file as a source. I named the fields like how they appeared in the CSV file (in the first row).

  • What happened?

Only the date and time column shows up. When I choose table view, the date and time column comes up, but the other column (force) is nowhere to be found. I get an error message saying that “Data is missing a number field.” Interestingly, when “ignore unknown” is turned off, the force column does show up. I already set the fields to number instead of string.

I suspect Grafana is having issues parsing/understanding the second column (force), that is why it is showing up in table view but not when I check “ignore unknown.” I have tried many things and have not been able to solve this issue. I tried converting the data into a float, removing extra whitespace, and keeping it as a string, none solved the issue.

  • What did you expect to happen?

I expected to have two columns of data (for time series visualization): date/time and force. So far I only have date/time.

  • Can you copy/paste the configuration(s) that you are having problems with?

table view with ignore unknown on

table view with ignore unknown off

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

The Grafana UI just says “data is missing a number field.” The logs don’t reveal anything interesting/important.

  • Did you follow any online instructions? If so, what is the URL?

If I’m not wrong, this error is generally arises if queried column data is not of numerical type. Check if the data in the Force column is in string form or not. If it is in string format then convert it into integer type.

After correction, things will look like this

In this correctly working image, “time-stamp” is the LHS(end) and “H_tot_def” column’s value in the RHS(end).

In the “columns field”, below the “data-set”" field, row names have ‘+/-’ sign befor them

1 Like