Problem with second y-axis on the right side

I use version v7.4.3 on a raspberry Pi.
I want to show the second y-axis on the right site. On the left side there should be a tempreature and on the right side power. But I get no scale for the right side and I don’t understand why?
If I put numbers to the fields min, max and decimals nothing changes. Maybe you can help me? Thank you!

welcome @obstbauer

You have an ancient version of grafana. newer version might have what you need?

1 Like

thanks for the answer
I tried this:

Grafana automatically updates when you run apt-get upgrade.

with sudo but I still have the same version
So I guess soemthing is wrong with my upgrade process ?

might want to look at the upgrade doco


  1. Does the output of “apt-get upgrade” suggest to you that a newer version of
    Grafana is getting installed? After all, “apt-get upgrade” is just a generic
    package upgrade process, which may or may not include Grafana.

  2. Did you restart Grafana after performing the upgrade?

  3. How are you determining which version you currently have?

  4. What’s the output of “apt-cache policy grafana”?


1 Like
  1. No

  2. Yes

  3. I can see it on my grafana site and with grafana-cli -v

  4. pi@raspberrypi:~ $ apt-cache policy grafana grafana: Installed: (none) Candidate: (none) Version table:

I had some errors because of my influx db because of this key, but I fixed it, now there are no errors if I perform update or upgrade commands

I tried the commands:

sudo apt full-upgrade
sudo apt upgrade
sudo apt-get update
sudo apt-get upgrade

$ apt-cache policy grafana
Installed: (none)
Candidate: (none)

This basically means you did not install Grafana as a .deb package (and
possibly don’t even have a repository for it in sources.list), and therefore
apt cannot upgrade it.


1 Like

ok… and what should I do now to fix it or to upgrade it ?

did you read the document for upgrade?

do you mean I should try the Binary .tar file upgrade method?

only you can answer that because we dont know how you installed the original one.

the other approach is to install new version of it in another folder, start it then stop it. then copy the data folder and the conf folder. I don’t know if that would work as I am not sure what OS and how you installed it. it depends.

my problem is thath I don’t know too :slight_smile :slight_smile:
I am a beginner , I use a raspberry pi with raspian

should I open an new topic ?

yeah try that approach and let us know. make sure to backup key folders first though. read the doco for that