Right y-axis doesn't show up after saving

Right y-axis is setup to show Temperature. Data is there and aligned for right y-axis but the ya-axis is missing after saving and won’t show up even after enable / disable.
Grafena Version 6.4.0

Hello Jochen!

You need to assign at least 1 series to the right y-axis, as it will not be rendered if there are no series assigned to it. You can assign series to right y-axis by clicking on series color icon or by using series override.


Hi Ivana,

Thanks for your reply. Please see my screenshot at the beginning. The second series is assigned to the right y-axis using series override. It has shown up correctly once and then disappeared.
In the series color dialog , it doesn’t allow to enable “Use right axis”. Any idea why?
Image1

I was trying to recreate the bug, but unfortunately I wasn’t able to. Could you maybe tell me more about your settings

  • Grafana version
  • Data source type & version
  • OS Grafana is installed on
  • User OS & Browser
  • Grafana plugins
  • Others

And include panel json and query inspector request/response as well.

I recreated this panel from scratch, then it is working. I guess it might be a settings problem due to previous versions fo grafana. However, there are many others and I don’t want to rcreate all of them.

So try this one to enable right y-axis.

Blockquote
{
“datasource”: null,
“aliasColors”: {},
“bars”: false,
“dashLength”: 10,
“dashes”: false,
“fill”: 1,
“fillGradient”: 0,
“gridPos”: {
“h”: 8,
“w”: 24,
“x”: 0,
“y”: 61
},
“id”: 13,
“legend”: {
“avg”: false,
“current”: false,
“max”: false,
“min”: false,
“show”: true,
“total”: false,
“values”: false
},
“lines”: true,
“linewidth”: 1,
“links”: ,
“nullPointMode”: “null”,
“options”: {
“dataLinks”:
},
“paceLength”: 10,
“percentage”: false,
“pointradius”: 2,
“points”: false,
“renderer”: “flot”,
“seriesOverrides”: [
{
“alias”: “Waschmaschine [Wh] [09-PSM-136]”,
“bars”: true,
“color”: “#56A64B”,
“lines”: false
},
{
“alias”: “Waschmaschine [W] [09-PSM-102]”,
“color”: “#FADE2A”,
“linewidth”: 2,
“zindex”: 0
}
],
“spaceLength”: 10,
“stack”: false,
“steppedLine”: true,
“targets”: [
{
“format”: “time_series”,
“group”: ,
“metricColumn”: “none”,
“rawQuery”: true,
“rawSql”: “SELECT\n ts AS “time”,\n val as “Waschmaschine [W] [09-PSM-102]”\nFROM ts_number\nWHERE\n $__unixEpochFilter(ts / 1000) and (id = 102)\nORDER BY ts asc;”,
“refId”: “B”,
“select”: [
[
{
“params”: [
“value”
],
“type”: “column”
}
]
],
“timeColumn”: “time”,
“where”: [
{
“name”: “$__timeFilter”,
“params”: ,
“type”: “macro”
}
]
},
{
“format”: “time_series”,
“group”: ,
“metricColumn”: “none”,
“rawQuery”: true,
“rawSql”: “SELECT\n ts - (3600 * 1000) AS “time”,\n val as “Waschmaschine [Wh] [09-PSM-136]”\nFROM ts_number\nWHERE\n $__unixEpochFilter(ts / 1000) and (id = 136)\nORDER BY ts asc;”,
“refId”: “A”,
“select”: [
[
{
“params”: [
“value”
],
“type”: “column”
}
]
],
“timeColumn”: “time”,
“where”: [
{
“name”: “$__timeFilter”,
“params”: ,
“type”: “macro”
}
]
}
],
“thresholds”: ,
“timeFrom”: null,
“timeRegions”: ,
“timeShift”: null,
“title”: “PSM09: Waschmaschine”,
“tooltip”: {
“shared”: true,
“sort”: 0,
“value_type”: “individual”
},
“type”: “graph”,
“xaxis”: {
“buckets”: null,
“mode”: “time”,
“name”: null,
“show”: true,
“values”:
},
“yaxes”: [
{
“format”: “locale”,
“label”: null,
“logBase”: 1,
“max”: null,
“min”: null,
“show”: true
},
{
“format”: “short”,
“label”: null,
“logBase”: 1,
“max”: null,
“min”: null,
“show”: false
}
],
“yaxis”: {
“align”: false,
“alignLevel”: null
}
}

Maybe if you could try to modify seriesOverride directly in your in your Panel JSON → add there "yaxis": 2 and save it → so it is going to be:

{
"alias": “Waschmaschine [Wh] [09-PSM-136]”,
"bars": true,
"color": “#56A64B”,
"lines": false,
"yaxis": 2
},```

This works!
Thank you very much for your support.

I am very glad to hear that! :tada::tada::tada::tada: