Plugin catalog not accessible via Grafana console

  • What Grafana version and what operating system are you using?
    v8.0.0 on Amazon Linux 2

  • What are you trying to achieve?
    Access the plugin catalog.

  • How are you trying to achieve it?
    Through the console, which is behind a corporate firewall, seems to need a proxy setting.

  • What happened?
    Plugin/Catalog pages says ‘Loading results’ forever for both Browse/Library menus

  • What did you expect to happen?
    Would see catalog with plugins listed.

  • Can you copy/paste the configuration(s) that you are having problems with?
    Included ‘plugin_admin_enabled’ as true in config.

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    t=2021-06-09T16:24:46+0000 lvl=eror msg=“Request Completed” logger=context userId=1 orgId=6 uname=admin method=GET path=/api/gnet/plugins status=502 remote_addr=X.X.X.X time_ms=30 size=0 referer=https://appmonitor-sbx3dev.cloud.statestreetlabs.com/a/grafana-plugin-admin-app
    t=2021-06-09T16:24:46+0000 lvl=info msg=“Request Completed” logger=context userId=1 orgId=6 uname=admin method=GET path="/public/img/icons/unicons/icon-gf icon-gf-apps.svg" status=404 remote_addr=X.X.X.X time_ms=11 size=54014 referer=https://appmonitor-sbx3dev.cloud.statestreetlabs.com/a/grafana-plugin-admin-app
    t=2021-06-09T16:24:50+0000 lvl=eror msg=“Request Completed” logger=context userId=1 orgId=6 uname=admin method=GET path=/api/gnet/plugins status=502 remote_addr=X.X.X.X time_ms=43 size=0 referer=https://appmonitor-sbx3dev.cloud.statestreetlabs.com/a/grafana-plugin-admin-app/library

  • Did you follow any online instructions? If so, what is the URL?
    https://grafana.com/docs/grafana/next/plugins/catalog/

Hi @wkneewalden

See anything interesting in the network tab of your browser dev tools?

Thanks for the response! The following shows up dev tools network tab that seems related:

Failed to load resource: the server responded with a status of 502 ()        /api/gnet/plugins:1
Uncaught (in promise)       tslib.es6.js:75
Object
config: {method: "GET", url: "api/gnet/plugins", params: undefined, requestId: undefined, retry: 0, …}
data: {error: "", response: "", message: ""}
status: 502
statusText: ""
__proto__: Object
Failed to load resource: the server responded with a status of 404 ()    /public/img/icons/un...0icon-gf-apps.svg:1
DevTools failed to load SourceMap: Could not load content for https://******.com/public/lib/monaco/min-maps/vs/loader.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

thanks @wkneewalden and sorry for the delay.

b/c this is still behind a feature toggle, I think that any feedback about config issues would be super valuable to the squads. If you’re still encountering this, I’d recommend making an issue in the repo.

looks like the plan rn is to merge the plugins-catalog into core Grafana for 8.1:

Thanks! I will check this again with v8.1 after change.

1 Like