Okta authentication through a web proxy


Apologies if this topic has been covered before, I couldn’t find anything by searching.
I’m trying to setup authentication via Oauth / Okta and need some advice on the correct way to setup access via a proxy server.

I’m running Grafana is 8.3.4 on RedHat EL8.7.

I’ve looked at plethora of posts on a variety of sites, each with some subtle differences in the suggested resolution.

From what I understand, there is no provision within Grafana to specify the details for a proxy server. It has to be configured within the grafana-server service.

To achieve this I’ve added the proxy server details into the /etc/sysconfig/grafana-server file.

Based on other people’s experiences, I’ve tried the following combinations. Basically variable name in both upper and lower case and with and without the “http://”.


Checking the environment for the service shows that the parameter is successfully set.

But it hasn’t worked with any of the options that I’ve tried. The same result, it times out whilst trying to connect to the Okta website.

Setting the proxy server details as a shell variable allows me to connect to the Okta site successfully. So I can only assume that I’m not matching the correct variable name that Grafana is looking for the proxy settings.

Obviously I’m not giving Grafana what it is expecting.

Any advice would be gratefully received.


I would be more specific, because SSO is complex and “it hasn’t worked” doesn’t give any clue what is a problem.

Grafana times out whilst trying to connect to the Okta website. The browser returns a “xxx.okta.com took too long to respond” error.

ok, so it is a problem of your computer. Your browser (OS) must have configured proxy, so your browser will go through proxy.