OAuth using proxy when I don't want it to

I am trying to configure generic_oauth but it’s not working - after the OAuth provider has done it’s work, it never comes back to the callback url. I’ve eventually spotted that, after a few minutes, the log file includes an entry

t=2020-08-28T20:09:50+0100 lvl=eror msg=login.OAuthLogin(NewTransportWithCode) logger=context userId=0 orgId=0 uname= error="Post https://<oauth-url>/eiam/oauth2/token: dial tcp <proxy-ipaddress>:443: connect: connection timed out"

(I’ve removed the actual urls and ips). Basically, it looks as though grafana-server is trying to use the IP address of a proxy to connect to the oauth service, which it shouldn’t. However, I cannot work out where this proxy setting is coming from. It’s not in grafana.ini. There was no proxy set in /etc/environment (although I have since tried adding a NO_PROXY entry there and restarting, but with no change). The grafana user that the server runs as does not have a home directory and so does not have it’s own .profile, so where is the setting coming from and how do I remove it?


OK, I was mis-reading logs. The issue was that it was NOT using the https_proxy when it needed to. Although the correct https_proxy was set in /etc/environment this wasn’t being used, but I was able to fix the issue by adding the https_proxy setting to /etc/default/grafana-server