Not able to connect my MS sql server Database Source

Hi,
I am Not able to add my Ms Sql server database sorce .
My default host for grafana is 3000
My Sql server database is on my local machine
pls find image below

What version of SQL Server? Can the grafana host reach your local machine, i.e. ping 192.168.13.124?

Ms sql server 2012 version.
yes, telnet 192.168.13.124 :3000 is pinged successfully

What error message do you receive when trying to connect? What Grafana version? telnet 192.168.13.124 :3000 seems like your “pinging” grafana, or are you running grafana and sql server on the same machine?

error message :
Unable to open tcp connection with host ‘192.168.13.124:1433’: dial tcp 192.168.13.124:1433: connectex: No connection could be made because the target machine actively refused it.

Both grafana and Ms sql server is running on same machine

Please use localhost:1433 then instead of 192.168.13.124:1433. Any difference?

When i am using localhost:1433
error message :

Unable to open tcp connection with host ‘localhost:1433’: dial tcp 127.0.0.1:1433: connectex: No connection could be made because the target machine actively refused it.

How does it look when you connect using sql server management studio for example, hostname/ip etc? Can you connect then?

d1
please look in picture

please find below two pic and their error messages

Don’t think SQL Server Express supports encryption.

If you try with host localhost:1433 again and change User to sa; encrypt=disable does that make any difference?

Another possible thing could be that tcp/ip is disabled. You must enabled it: http://support.webecs.com/kb/a868/how-do-i-configure-sql-server-express-to-allow-remote-tcp-ip-connections-on-port-1433.aspx

i done above step.
the output is

i done above step.
the output is

Please try and disable the firewall just to make sure that’s not the issue.
Please try with the IP you had first
Please try with the IP you had first and localhost changing User to sa; encrypt=disable

hi, i had ‘… actively refused’ too. SQL2017 and Grafana 6 both on localmachine with Windows 10.
Looking at the Windows Logs Application at the SQL Service restart messages i found:
“Server is listening on [ 127.0.0.1 1434].”
So changing to localhost:1434 fixed it :wink:

1 Like

Hi All,

I am having the same issue, it seems that none of the above action item is working.
Can you please help.

Hi,

I soved this issue by the following steps:

  • Open Sql Server Configuration Manager
  • From the left sidebar select and expand SQL Server Network Configuration
  • Select Protocols for MSSQLSEREVER
  • Then just enable TCP/IP and Named Pipes protocols
  • Restart SQLServer Service.
5 Likes

A combination of what you have listed and what WillianV said above worked for me. In the log I found “Server is listening on [‘any’ 61438]” When I changed to port 61438 I got a connection.

I have the same issue but I have not fixed it using your method :stuck_out_tongue: