Line interpolation -> step after not always working

I have a field that gets visualized anomaly: I’ve selected the line interpolation step after so that the zero could be kept until the next value.
This works on certain zoom:

but if I zoom out, the line is at the next value just after the zero (green line):

How comes? Am I doing something wrong?
Grafana version: 8.5.3 (409e9bc9a5)
Datasource: InfluxDB
Visualization: time series
No error received.

Hi @pereus,

Welcome to the :grafana: community support forums !!

Please review the submission template and include more details:

  • What Grafana version and what operating system are you using?
  • What is your datasource?
  • What visualization panel you are using e.g. time-series, bar chart, histogram etc?
  • What are you trying to achieve?
  • How are you trying to achieve it?
  • What happened?
  • What did you expect to happen?
  • Can you copy/paste the configuration(s) that you are having problems with?
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
  • Did you follow any online instructions? If so, what is the URL?

Sorry about that… :frowning:
I’ve updated my post with the information needed.
The one missing is the configuration because…I don’t know how to export the configuration of the graph.

Hi @pereus,

Thanks, so I think your data is live one and not sure if you can reproduce it on (if you can then please do and share the steps of reproduction).

Also, did you try to play around with the settings on the right side such as (shown in the screenshot):


As it might help somehow. Otherwise try to see if you can reproduce it on any newer grafana version or even at

Hi @usmanahmad
thanks to your post I could solve the issue!
I went to export the InfluxDB data to import them into and I’ve noticed that the 0 value was never there! What the heck! I’ve then noticed that the InfluxDB data that were aggregated with a mean function and so the zero was never there.
I’ve removed the aggregation and the problem is gone!

1 Like