Installation or Setup image renderer by docker container

Dear Community,
I am a starter with Grafana and special the Image Render.
I would like to send some graph by Telegram to my mobile and about this I need to create a Picture PNG file to be able to create.
To creating and setup the Docker Containers on Raspberry Pi I use Portainer also in a container.
The Versions I use for Grafana is as follow:
Grafana: V8.3.4
Image Renderer: adejong/grafana-image-renderer-pi:1.0.8-beta2

If I use the original

grafana/grafana-image-renderer:latest

the Container will not start about this error

standard_init_linux.go:228: exec user process caused: exec format error

as I understood the container is not compatible with the Raspberry but I am not sure.

In Portainer I user Stacks instaead of docker complose file but it is the same as I read.
My file is as follow

version: "2"

services:
  grafana:
    image: grafana/grafana:latest
    container_name: grafana
    environment:
      GF_RENDERING_SERVER_URL: http://renderer:8081/render
      GF_RENDERING_CALLBACK_URL: http://grafana:3000/
    network_mode: bridge
    ports:
      - 3000:3000
    links:
      - renderer
    volumes:
      - /opt/grafana/lib:/var/lib/grafana
      - /opt/grafana/ini:/etc/grafana
      - /opt/grafana/log:/var/log/grafana
      - /opt/grafana/json/config.json:/usr/src/app/config.json
  renderer:
    image: adejong/grafana-image-renderer-pi:1.0.8-beta2
    container_name: grafana-image-renderer-pi
    network_mode: bridge
    ports:
      - 8081:8081

After starting the Stack I connect to Grafana and I can see under share the possibility to create a PNG File.


But when I push the button I receive an error message.
2
When I check the Server LOG File I saw the follow information.

t=2022-01-31T16:20:23+0000 lvl=dbug msg="Scheduling update" logger=alerting.scheduler ruleCount=1
t=2022-01-31T16:20:29+0000 lvl=info msg=Rendering logger=rendering renderer=http path="d-solo/L43cYuRgk/heizungsauswertung?orgId=1&from=1643624427296&to=1643646027296&panelId=2&width=1000&height=500&tz=Europe%2FBerlin"
t=2022-01-31T16:20:29+0000 lvl=dbug msg="calling remote rendering service" logger=rendering renderer=http url="http://renderer:8081/render?deviceScaleFactor=1.000000&domain=grafana&encoding=&height=500&renderKey=sAFFuAtFJPmYAT3gosAWhkMkt8GMz0tY&timeout=60&timezone=Europe%2FBerlin&url=http%3A%2F%2Fgrafana%3A3000%2Fd-solo%2FL43cYuRgk%2Fheizungsauswertung%3ForgId%3D1%26from%3D1643624427296%26to%3D1643646027296%26panelId%3D2%26width%3D1000%26height%3D500%26tz%3DEurope%252FBerlin%26render%3D1&width=1000"
t=2022-01-31T16:20:29+0000 lvl=eror msg="Failed to send request to remote rendering service" logger=rendering renderer=http error="Get \"http://renderer:8081/render?deviceScaleFactor=1.000000&domain=grafana&encoding=&height=500&renderKey=sAFFuAtFJPmYAT3gosAWhkMkt8GMz0tY&timeout=60&timezone=Europe%2FBerlin&url=http%3A%2F%2Fgrafana%3A3000%2Fd-solo%2FL43cYuRgk%2Fheizungsauswertung%3ForgId%3D1%26from%3D1643624427296%26to%3D1643646027296%26panelId%3D2%26width%3D1000%26height%3D500%26tz%3DEurope%252FBerlin%26render%3D1&width=1000\": dial tcp: lookup renderer on 192.168.1.1:53: no such host"
t=2022-01-31T16:20:29+0000 lvl=eror msg="Rendering failed." logger=context userId=1 orgId=1 uname=admin error="failed to send request to remote rendering service: Get \"http://renderer:8081/render?deviceScaleFactor=1.000000&domain=grafana&encoding=&height=500&renderKey=sAFFuAtFJPmYAT3gosAWhkMkt8GMz0tY&timeout=60&timezone=Europe%2FBerlin&url=http%3A%2F%2Fgrafana%3A3000%2Fd-solo%2FL43cYuRgk%2Fheizungsauswertung%3ForgId%3D1%26from%3D1643624427296%26to%3D1643646027296%26panelId%3D2%26width%3D1000%26height%3D500%26tz%3DEurope%252FBerlin%26render%3D1&width=1000\": dial tcp: lookup renderer on 192.168.1.1:53: no such host"
t=2022-01-31T16:20:29+0000 lvl=eror msg="Request Completed" logger=context userId=1 orgId=1 uname=admin method=GET path=/render/d-solo/L43cYuRgk/heizungsauswertung status=500 remote_addr=10.1.1.28 time_ms=65 size=1344 referer=
t=2022-01-31T16:20:31+0000 lvl=dbug msg="Received unknown frontend metric" logger=context userId=1 orgId=1 uname=admin metric=frontend_boot_first_contentful_paint_time_seconds
t=2022-01-31T16:20:33+0000 lvl=dbug msg="Scheduling update" logger=alerting.scheduler ruleCount=1
t=2022-01-31T16:20:43+0000 lvl=dbug msg="Scheduling update" logger=alerting.scheduler ruleCount=1

I checked different sides but I was not able to find a solution for this or I am not able to understand the correct problem.
Thanks
Thomas

Dear all,

nobody any Idea?

Thanks

thomas

Error indicates problem with your (Docker/container) networking, not with Grafana configuration. I would say also link is deprecated docker feature. I would create custom network for the stack, where each container can call each other by service name.

Dear jangaraj,

first thanks for your answere.
For me everything is new docker and Grafana settings as well.
When I use Docker than on easy way like it is in the Doc and until now it works.

After useing Grafana I try to install Grafana only but I faced that the Plugin for the Renderer will not work anymore so I thought that it will be the best to install Grafana and the Renderer in a Stack and I follow the instructions on Grafna com and other Websides.
90% of the Docker compose file isfrom the Grafana instruction I only modify/add the Volumes.
On Docker I have only 3 Container Grafana, Renderer and InfluxDB.
When I open Grafana and the Renderer Container is stoped I cannot see the Direct Link to the Renderer so the communication between the Container should somehow function.
I also try the IP Adress directly but with the same result NG.
Maybe you can give me a easy instruction how to setup the Stack.
I read form many people and they use Grafana and Renderer on Docker but I cannot understand why it is not running.

Thanks for reading

Thomas