Grafana Rendering for Raspbian Jessie on Raspberry Pi 3 B in End of Year 2019 - still possible?

I have been trying to setup Grafana and Image Renderer on Raspbian , but I always encountered some incompatibility issues one way or another. Things I have tried are pretty much from https://grafana.com/docs/administration/image_rendering/ :

  1. Grafana 6.3.6 in Docker + Running Image Renderer as standalone Node.js application: the Node.js could run, but I end up getting

Syntax error: word unexpected

from the Node.js output, which is basically this issue: https://github.com/grafana/grafana-image-renderer/issues/7#issuecomment-436065864

I did tried different versions of ChromeDriver but I still got the errors.

PS. I grabbed Grafana 6.3.6 because Docker seems to have incompatibility issue for ARM CPU for higher version of Grafana Docker.


  1. Since the point above is filled with “compatibility riddles”, I decided to move on for the Docker Compose route in “Remote rendering service” section of https://grafana.com/docs/administration/image_rendering/.

Since this method is compatible with Docker version of Grafana, let’s go with that. …but the only problem is I couldn’t because “docker-compose” is only supported on 64 bit Linux as specified here: https://docs.docker.com/v17.09/compose/install/. Installing it and trying to run

docker-compose --version

will result in

/usr/local/bin/docker-compose: line 1: Not: command not found


  1. So another thing I tried is to the non-Docker route. I grabbed the native version:

wget https://dl.grafana.com/oss/release/grafana_6.4.4_armhf.deb

and installing. Everything works fine, so let’s install the grafana image renderer with the grafana-cli:

grafana-cli plugins install grafana-image-renderer

And that yields:

Error: âś— Plugin is not supported on your architecture and os.

So am I out of luck for this?

What am I after is simply to generate PNG images of all panels of all Dashboards in Grafana daily. Is there any other way to do this?

1 Like