How to hide "filter out value" and "filter for value" option in table columns

Is there a way to remove or hide those filters because if it is clicked by mistake it makes changes to all the panels and no graphs are visible.


@sanyogvyawahare , Did you find a way to do this?


Can you provide more context? what task are you trying to accomplish where the filters are potential distractions. Here is some information on how to clear filters: Filter table columns | Grafana Labs

Hope this helps.

@aparajitachatterjee Thanks for your help!

I’m trying to get rid of these two small filter options: “Filter for value” and “Filter out value”, while using the Table visualization.

See below image for a better understanding.


1 Like

Hello, have you find a solution for that

1 Like

Nope :frowning:
I’m still trying to figure this out


In the css of class .table-panel-filter-link you can set display to none. Right now this is the closest I was able tohide these filters links and icons.

1 Like

Any news on this problem ? These buttons are really annoying.
For example when you set the cells to be center-aligned, and hover the mouse over the cell, the text move to the left. If your text in a link, then you just missclick it.
An option to disable those two buttons would be nice.

I’m also looking for a solution for this. Did you find one ?

HI, Can you give me an example? 'Cause I don’t understand where is the CSS in the edit panel settings.
Thanks Alen


I’m having trouble making those icons appear. I guess I have the opposite problem. Can anyone provide steps to reproduce this behavior in Grafana v9?

Hi, I know I’m a little late but for anyone who needs this in the future: To enable/disable this feature, add a new override. In the Overrride Property select Standard Options > Ad-Hoc-filterable. Then you can switch it on or off for the specified fields.


Sorry, I could not find the “standard options” when I tried to edit panel. Am I looking at the wrong place. I have attached a screenshot of this.

Select “Fields with name” and not “Fields with values”.