How to change refresh-rate from 5s to 1s

Hey guys,

I want to make a panel that refreshes every 1 second not every 5 seconds. I already tried to change the minimum refreshrate in the grafana.ini, but the options in the dashboard settings doesn’t change after a restart. Every time I try to change it to a lower value than 5 it just disappears. Is ist possible to change that?

Thanks for every help.

Hi!

Enter in your dashboard, click on the top of page in the button “Dashboard Settings”

And add “1s,” in this textbox:

I hope it could fix your problem

Hi,

did you try it yourself? When I put 1s in, it just disappears.

Also needed:

grafana.ini
[dashboards]
min_refresh_interval = 1s

Then restart grafana

I already did those steps. But as soon as I try to change the 5s into 1s in the dashboard settings, the 1s I just wrote disappears. I already changed the frafana.ini. Does it work for u guys? Would appreciate it, if someone could try it out. :slight_smile:

Now it worked. Found this topic https://github.com/grafana/grafana/issues/710. The problem was the semicolon infront of the min_refresh_interval = 1s. Thanks for your answers :slight_smile:

2 Likes