Lowest Refresh Rate Now 5s?

We had some 1s update panels that we used to tune systems in realtime. We will not be able to use the panel anymore. Is there a reason this was done? It seems like it began in version 7.

1 Like

You have still option to configure that in your config file:

[dashboards]
# Minimum dashboard refresh interval. When set, this will restrict users to set the refresh interval of a dashboard lower than given interval. Per default this is 5 seconds.

# The interval string is a possibly signed sequence of decimal numbers, followed by a unit suffix (ms, s, m, h, d), e.g. 30s or 1m.

min_refresh_interval = 5s

1 Like

Thanks for this. I did so much searching and there isn’t info out there on this yet. I didn’t go read the new config file defaults though as all my configs are old.

It is mentioned in the release notes https://github.com/grafana/grafana/releases
Breaking change section and also link to the PR in the features section:

  • Dashboard : Enforce minimum dashboard refresh interval to 5 seconds per default. #23929, @marefr
1 Like

Thank you for this information!!! I was also struggling with this issue.

My question is, why would the 1s option be removed from the drop down menu if it is still possible? Lots of organizations use Grafana for near-realtime displays.

2 Likes

I would agree that being able to remove it from the panel settings is enough if someone doesn’t want a lower than 5s delay. There may be better reasoning behind it but it seems redundant to block it on the server side unless its to prevent end users from being able to poll any faster without an admins knowledge or something.

1 Like

This creates problems for me. My users spin up a server locally to look at realtime data. Now I have to ask all of them to do a manual change to their config file. Where is even the config file located? Now I and all my users have to lean about that.

I kindly ask that 1s refresh rate can again be configured freely through the GUI per default.

EDIT: To show what problem this creates, let’s see how I go about to fix it.
Where even is the config file? I installed Grafana with the Windows installer so I didn’t choose a location, but I guess “Program files” which turns out correct. Searching on Google finds https://grafana.com/docs/grafana/latest/administration/configuration/#config-file-locations
So I copy conf/sample.init to conf/custom.ini. Searching in the file for “5” finds min_refresh_interval setting which I change. But “Program files” is a protected location to make changes in. Fortunately Notepad++ easily changes to Administrator to let me make the change but this could be jarring for a novice.
Does the file reload by itself… no.
So how do I restart Grafana? With the Windows installer, I didn’t have to start it at all. There’s no option in the Start menu. The task manager shows grafana_server.exe, but I can’t seem to stop it from task manager. Or did it actually restart? Trying to set refresh rate 1s still doesn’t work, so I guess no.
And is “custom.ini” even used by default?
Google doesn’t help me how to restart Grafana; possibly by installing a 3rd-party tool to manage services. Nah, too much work. And I can’t restart my computer now.
So for now I’m out of luck and have to do with 5 second refresh rate.

You need to put a value that’s lower than the refresh rate you want. If you want a 1s refresh rate, try setting min_refersh_interval = 100ms. I’m sure 999ms would work, but I haven’t tried it.

After you restart Grafana, you should be able to add 1s to the comma separated list in the Dashboard settings.

Save the Dashboard, and you will now be able to select 1s in the Auto-refresh dropdown.

Problem on Windows is’nt solved for present day. Changes of .ini gives nothing, grafana-server can’t be stopped from task manager
P.S. I don’t see any reasons for this action (restrict acces to 1s and lower). It’s forcing to admins for a new task with our customers.