Folder permissions issue

Hi all,
I have strange problem with grafana Grafana v7.0.0.
When I create new folder for dashboards, I cant delete default access rights in Folder Permissions tab. It is always give error - Permission already exists, it is very strange, coz I want to delete them.
Also, I new folder is created with double same roles in this tab, maybe problem here, but I dont know why.
Same error I have, when trying add any permission.

PS.
I tried latest version of Grafana and it have same problem.
I dont know, when problem started, coz not often creating new folders, but all old folders work perfectly with permissions.

1 Like

Hi,

Please note that you are using a Gold version 7.0.0, there has been a lot of bug fixes and improvements meanwhile. I suggest you install a later version adn test.

Good Luck

Hi,

Thanks for you reply, but as I wrote, I tried use latest grafana version and it is didnt help.
I do some research and found, that problem somewhere in database coz when I install fresh grafana instance, permissions work correctly, before as I copied old DB.

Hi,

Oh sorry didn’t read that, seems that your db got corrupted along the way. Is it feasible to migrate your dashboards to the new install or it is too much work. When you reproduce the issue is anything logged in grafana logs ?

Good Luck

In grafana logs I see same error message, that from GUI, that user “XXX” has tried to change permission, but cant do it because them already exist.

Yes, I have plan to migrate dashboard to new instance with fresh DB, but maybe someone know, how it can be fixed.

This just happened to me as well. Any updates if there is a fix or is creating a new instance the best course of action?

Hi,

Is it a new install or did something change in your configuration before you saw that message ?

Which version are you using?

Good Luck

Hello!
I’m using 7.5.2. It is an pre-existing installation. As far as what changed in the configuration, it’s hard to say. I haven’t had to go into the permissions section for about a month or two and only needed to go there since I had to create a new folder to house some new dashboards. I have created many dashboards, performed updates, etc since then.

I also noticed this same issue. Duplicate Editor and Viewer permissions defined and unable to delete or add to permissions with the same error shown in the image of post #1.

After investigation of the database I noticed that there were duplicate rows for Editor and Viewer in the dashboard_acl table. I am using enterprise Grafana v7.5.3 on CentOS and the sqlite3 database that is there by default.

There are unique constraints defined on the dashboard_acl table but it appears that when one of the column values is NULL that this constraint is ineffective. The duplicate rows had a dashboard_id of -1 and NULL values for user_id and team_id.

In summary the way I resolved this issue was to delete the extra duplicate rows from the sqlite3 database used by my Grafana install. I identified the rows to delete based on created/updated column values and compared rows to a clean install. Just make sure you take a back-up or are able to insert anything you delete. I don’t think there were any cascading deletes but I did not check as thoroughly as I should.

Once the rows were deleted I was able to add/remove permissions in the GUI without error and the duplicates were no longer present.

No idea why this was affecting my Grafana install. It is something I inherited and already came with the issue. Never seen it on any clean new installations.

Hi guys!
I had the same error and fixed it with Salgh’s help.
Here is the step by step:

  1. Log in in Grafana server.
  2. Install sqllite: apt install sqlite3
  3. Backup old database, just in case! : cp /var/lib/grafana/grafana.db /var/lib/grafana/grafana.db.bkp
  4. Enter to database… sqlite3 /var/lib/grafana/grafana.db
  5. Select rows with error: SELECT * from dashboard_acl where dashboard_id = '-1';
  6. Then, delete it: DELETE from dashboard_acl where dashboard_id = '-1';

I hope that this help the community :slight_smile:

4 Likes