Error after update plugin and restart

  • What Grafana version and what operating system are you using?

  • v8.1.2 (103f8fa094), Ubuntu Linux 20.04.2

  • What are you trying to achieve?

I wanted to make an update to zabbix grafana plugin

  • How are you trying to achieve it?

I am looking on the internet, I did not find anything … I turned off the plugin, restarted the grafan

  • What happened?

"Error

Post “http://192.168.3.3/zabbix/api_jsonrpc.php”: net/http: invalid header field name “”

  • What did you expect to happen?

that the updates are going to work?

  • Can you copy/paste the configuration(s) that you are having problems with?

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

"Error

Post “http://192.168.3.3/zabbix/api_jsonrpc.php”: net/http: invalid header field name “”

1 Like

I fixed this by removing the custom HTTP headers in the edit data source page

2 Likes

Thank you so much for writing the solution! I had the same error, when trying to use alerts with influxdb (normal queries in panels worked). This was also caused by an empty custom http header that somehow appeared in the datasource.

2 Likes