Cannot load custom plugin

I’m running grafana with docker, and I tried to follow this build a panel plugin tutorial
However, I can’t see my custom plugin on Grafana.

This is what my logs say:
msg=“Skipping loading plugin due to problem with signature”

Do the errors say something about signed/unsigned plugins? I know that if a plugin is unsigned, then Grafana does not load nor start it. So if that’s the case, should I sign my custom plugin first to work?

Or do I have to add GF_PLUGINS_ALLOW_LOADING_UNSIGNED_PLUGINS=“my-plugin” in the docker run command?

1 Like

Hi Ryan,

Have you tried setting the app mode to development? That will load all unsigned plugins. GF_PLUGINS_ALLOW_LOADING_UNSIGNED_PLUGINS should work too, but is typically better for when you want to allow a specific unsigned plugin in a production environment.

Hello @marcusolsson,

I am facing some issues related to datasource plugin development too in addition to the above, namely:

  1. console.log in the plugin code doesn’t print out on Firefox or CDT
  2. Variables are “not available” when you place a breakpoint and do a watch on them

Could you please tell me how to set the app mode to development?

For me the following worked:

  1. Set in the following in environment variable in Grafana container and restart the container

GF_DEFAULT_APP_MODE=development

  1. Build the react plugin with the following option and reload the plugin if you are switching mode from prod to dev. You don’t need to reload after this.

yarn dev

2 Likes