Local plugin doesn't load

I have grafana 8.4.3 installed, node 16.13.2 and yarn 1.22.17

Following instructions from Build a panel plugin | Grafana Labs

In /var/lib/grafana/plugins folder I’ve used command npx @grafana/toolkit plugin:create test-plugin. I entered the folder test-plugin and ran yarn install and yarn dev with no issues. After that i restarted grafana with service grafana-server restart.

The problem is i still don’t see my plugin listed in http://127.0.0.1:3000/plugins.

The issue is that i had no problem seeing the plugin after following this process in Grafana v7. Has something changed that requires an extra stemp for me to see the new plugin?

Can anyone at least confirm that they were able to create a plugin in Grafana 8 without any issues so that i know this is a problem on my end?

Hey,

By default, Grafana only loads signed plugins. While developing, I recommend that you start Grafana with GF_DEFAULT_APP_MODE=development to allow unsigned plugins as well. You should be able to see this in the server logs as well.

2 Likes

Thank you this actually fixed it!
I tried editing the allow_loading_unsigned_plugins variable in the grafan.ini config file in to:

# Enter a comma-separated list of plugin identifiers to identify plugins to load even if they are unsigned. Plugins with modified signatures are never loaded.

allow_loading_unsigned_plugins = "test-plugin"

But for some reason this didn’t seem to work so I thought that wasn’t the issue.
I set the
app_mode = development
grafana.ini and now it works.

1 Like