Custom plugin not starting

Hi All, I am trying to install the following pluging:

I did added it into the plugin folder and I did modified grafana.ini to start as development:

;app_mode = development

and to add unsigned plugins:

# Enter a comma-separated list of plugin identifiers to identify plugins to load even if they are unsigned. Plugins with modified signatures are never loaded.
;allow_loading_unsigned_plugins = globalnoc-worldview-panel

Logs

oot@i-02ec7dd6c1177d928:/var/lib/grafana/plugins# sudo systemctl status grafana-server
● grafana-server.service - Grafana instance
     Loaded: loaded (/lib/systemd/system/grafana-server.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-07-05 23:17:43 UTC; 5s ago
       Docs: http://docs.grafana.org
   Main PID: 80229 (grafana-server)
      Tasks: 14 (limit: 38509)
     Memory: 30.8M
     CGroup: /system.slice/grafana-server.service
             └─80229 /usr/sbin/grafana-server --config=/etc/grafana/grafana.ini --pidfile=/run/grafana/grafana-server.pid --packaging=deb cfg:default.paths.logs=/var/log/grafana cfg:default.paths.data=/var/lib/grafana cfg:default.paths.>

Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=plugin.manager t=2022-07-05T23:17:43.53+0000 lvl=info msg="Plugin registered" pluginId=input
Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=plugin.loader t=2022-07-05T23:17:43.6+0000 lvl=warn msg="Skipping loading plugin due to problem with signature" pluginID=globalnoc-worldview-panel status=unsigned
Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=plugin.manager t=2022-07-05T23:17:43.6+0000 lvl=info msg="Plugin registered" pluginId=satellogic-3d-globe-panel
Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=query_data t=2022-07-05T23:17:43.6+0000 lvl=info msg="Query Service initialization"
Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=live.push_http t=2022-07-05T23:17:43.61+0000 lvl=info msg="Live Push Gateway initialization"
Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=server t=2022-07-05T23:17:43.71+0000 lvl=info msg="Writing PID file" path=/run/grafana/grafana-server.pid pid=80229
Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=report t=2022-07-05T23:17:43.71+0000 lvl=warn msg="Scheduling and sending of reports disabled, SMTP is not configured and enabled. Configure SMTP to enable."
Jul 05 23:17:43 i-02ec7dd6c1177d928 grafana-server[80229]: logger=http.server t=2022-07-05T23:17:43.71+0000 lvl=info msg="HTTP Server Listen" address=[::]:3000 protocol=http subUrl= socket=
Jul 05 23:17:45 i-02ec7dd6c1177d928 grafana-server[80229]: logger=context userId=1 orgId=1 uname=admin t=2022-07-05T23:17:45.66+0000 lvl=info msg="Request Completed" method=GET path=/api/live/ws status=0 remote_addr=10.10.60.4 time_ms=6>
Jul 05 23:17:46 i-02ec7dd6c1177d928 grafana-server[80229]: logger=live t=2022-07-05T23:17:46.07+0000 lvl=info msg="Initialized channel handler" channel=grafana/dashboard/uid/CmvNY7_nk address=grafana/dashboard/uid/CmvNY7_nk

Hello,

Which plugin folder did you copy it to and did you restart grafana after copying it

1 Like

I just found the “;” at the beginning of the line in grafana.ini is the way to comment :slight_smile:

:wink: that is pretty much standard for all .conf in any application. So you have resolved your issue?

by removing the “;” from allow_loading_unsigned_plugins = globalnoc-worldview-panel in grafana.ini

2 Likes