Azure Grafana VM - First time password

I’m new to Grafana and I look forward to use it for a huge web saas application distribuited over several Azure regions.

I deployed the Azure VM template which is available in the marketplace.
I made all the networking and security configuration required.
I’m able to reach the Grafana login page.
At this point I’m not able to login with “admin/admin” credentials.It always fails. I tried many combination “Admin ADMIN etc”, no luck.
I went through the documentation and I could not find a way to manually set or reset credentials from command line.

I tried to update grafana (wget, still not luck.

I tried to reset the passwor from CLI and I hit the following error:

fecriv@grafana-vm:~$ grafana-cli admin reset-admin-password NewFancyPW00
Grafana-server Init Failed: Could not find config defaults, make sure homepath command line parameter is set or working directory is homepath

fecriv@grafana-vm:~$ grafana-cli admin reset-admin-password --homepath “/usr/share/grafana” newpass
INFO[05-05|21:19:12] Initializing DB logger=sqlstore dbtype=sqlite3
INFO[05-05|21:19:12] Starting DB migration logger=migrator
EROR[05-05|21:19:12] Fail to initialize orm engine logger=sqlstore error="Sqlstore::Migration failed err: unable to open database file\n"

I performed a new Grafana installation from a clean Ubuntu VM and the credentials “admin-admin” worked fine.
Maybe something wrong with the template image in Azure?

Any inputs? :slight_smile: