404 error when try to create a folder

I’m running the latest beta 4 of Grafana v5 on a server and it is working beautifully with 1 exception… When I click to add a new folder I get redirected to a page which says ‘Page Not Found, error 404’.

I do have Grafana running behind an IIS server with a redirect set up, but that works fine apart from for this one issue of creating a new dashboard. The url that is displayed when I get the 404 error is:

Anyone got any ideas what could be causing this please? Thanks.

In the grafana.log file there is this entry:
t=2018-02-21T11:10:14+0000 lvl=info msg=“Request Completed” logger=context userId=1 orgId=5 uname=admin method=GET path=/folder/new status=404 remote_addr=<my_ip>:52987 time_ms=3 size=15105 referer=

Thanks for the report. We will check it out and get a fix in soon. It should be /dashboards/folder/new. Do you get this error when clicking on the + icon and then folder or in another part of the UI?


Just tested this with a configured nginx proxy and I don’t have any issues with clicking on add folder from left main meny, in dashboard search or from the manage dashboards page.

If you browse https://[myserver.com]/grafana/dashboards/folder/new do you get the same error in the grafana.log? If so, I’m guessing that it is the IIS setup that’s wrong. Could you please include the IIS configuration here somehow? That would be helpful for us to investigate this further.



Thanks for the help with this. It was an issue with my IIS setup. Following these instructions helped me fix the issue.
I actually made a mistake in my original post too, my suburl was dashboards giving https://[mysite.com]/dashboards. I’ve now changed this to /grafana which seems to have helped too.

1 Like

The issue still exists. Steps to reproduce:
Use /dash as redirection url

root_url = %(protocol)s://%(domain)s:%(http_port)s/dash

<VirtualHost *:80>
ProxyPreserveHost On
ProxyPass /dash
ProxyPassReverse /dash

I just did a quick test with the apache docker block in the Grafana project and could recreate this. You are getting a conflict in the pattern matching.

Just change dash to something that does not conflict with dashboard or turn off ProxyPreserveHost (any reason you need that?).

Yeah, I already changed that.

So it works for you now?

Yeah it works if I use anything other then any substring of “dashboard”.

Great to hear you are up and running.