Zabbix Plugin for Grafana

Grafana Version 10.2.2 on Server 2019
Zabbix 6.0.25 (Ubuntu 22)
Grafana Zabbix Version 4.4.4

When trying to connect the new data source, I am getting this error “An error occurred within the plugin”

grafana log says this:

logger=context userId=1 orgId=1 uname=admin t=2023-12-14T14:46:36.8500116Z level=info msg="Request Completed" method=GET path=/api/gnet/plugins/alexanderzobnin-zabbix-datasource status=404 remote_addr=10.95.11.22 time_ms=56 duration=56.5096ms size=116 referer=http://nla-apps01:3000/connections/datasources/alexanderzobnin-zabbix-datasource handler=/api/gnet/*

So far I have tried:

Uninstalling the plugin and installing via the grafana-cli
Adding the plugin to the defaults.ini file to bypass the unsinged error

Has anyone seen this before?

Thanks!

Could you explain what “When trying to connect the new data source” means, pls?

Try

grafana-cli plugins remove alexanderzobnin-zabbix-app 4.4.4
grafana-cli plugins install alexanderzobnin-zabbix-app

But, can you send a printout of how your Zabbix datasource is configured and the error message?

Morning,

Tried that, unfortunately the same error.

See the screenshots of the config.

Thanks


Display a message: “Plugin unavailable”.
I don’t have experience with grafana on Windows Server, but check the permissions of the files in the plugin folder, I would also try to remove the plugin and install it using the plugin installation button in the grafana frontend, in the plugins section.

In the end I installed Grafana on the same server as Zabbix and it’s now working! Thank you for your help on this one