Zabbix Grafana Integration request failed, status: 404 Not Found

  • What Grafana version and what operating system are you using? Grafana 8.2.4 Ubuntu 20.0.4

  • What are you trying to achieve? Integration between Zabbix and Grafana via plugin.

  • How are you trying to achieve it? Downloaded plugin to Grafana, issue occurs when trying to add Zabbix as a data source.

  • What happened? request failed, status: 404 Not Found

  • What did you expect to happen? Integration between Zabbix and Grafana

  • Can you copy/paste the configuration(s) that you are having problems with? Yes via screenshots if requested.

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were. request failed, status: 404 Not Found

  • Did you follow any online instructions? If so, what is the URL?
    I am looking to integrate Zabbix with Grafana. For this project I spun up a new Ubuntu 20.0.4 VM and followed this walkthrough exactly for the Zabbix install: Zabbix Monitoring: The Ultimate Guide and this install exactly for the Grafana install: https://linuxways.net/ubuntu/how-to-…-ubuntu-20-04/

I can successfully install the Zabbix for Grafana plugin, when I go to select Zabbix as a data source I follow the plugin directions exactly.
I have also tried other solutions found online to change login “Access” from Server to Browser, and to remove /zabbix/ in the URL. I am also replacing ‘hostname’ in the URL with the IP of the VM running both Grafana and Zabbox. None of these solutions work I always receive

request failed, status: 404 Not Found

I am able to access both Grafana and Zabbix via HTTP and at localhost:80 shows the Apache default index page. Looking for assistance I am out of ideas.

Hi,

Did you try the solution mentioned here

If yes, please share with us a screenshot for your current configuration.

Good Luck

Yes I tried this with no luck. Screenshot of my configuration is below:
in regards to the URL i have tried
http://localhost/zabbix/api_jsconrpc.php
http://localhost/api_jsconrpc.php
https://localhost/zabbix/api_jsconrpc.php
http://127.0.0.1/zabbix/api_jsconrpc.php
http://127.0.0.1/api_jsconrpc.php
https://127.0.0.1/zabbix/api_jsconrpc.php
http://10.200.10.19/zabbix/api_jsconrpc.php
http://10.200.10.19/api_jsconrpc.php
https://10.200.10.19/zabbix/api_jsconrpc.php

Deleted the VM this morning and did a fresh install of Zabbix and Grafana, issue persists.

Hi,

Can you curl to any of the addresses ?

curl https://127.0.0.1/zabbix/api_jsonrpc.php

Also do you have firewall / selinux enabled ?

Good Luck

Make sure that you use apache to connect with zabbix. Because I have installed nginx, so my 80 port is used for nginx, and it keeps me generating error message. You should specify the apache’s port if you have also installled nginx