Trouble connecting grafana with zabbix

Recently i was trying to connect grafana to zabbix.I have installed zabbix plugin to grafana.I could see the plugin in the plugin section but could not see it when i tried to create new datasource.However, i have managed to use it in create datasource section by adding it into /usr/share/grafana/conf/defaults.ini with allow_loading_unsigned_plugins = alexanderzobnin-zabbix-datasource.
But this time i am getting this error when i try to save&test datasource request failed, status: 404 Not Found. Versions:
Zabbix : 5.2
grafana : 7.1.5
grafana-zabbix plugin : 4.0.1

Would appreciate any help :slight_smile:

1 Like

I had the same issue on a very similar configuration (Zabbix server is 5.0.4).
My issue was an unnecessary “/zabbix” folder in the URL path. Correct - which works for me is: http://localhost/api_jsonrpc.php
Without “/zabbix” works as should. This may be verified just by trying to open an indicated address in a browser. When trying to open the default path You’ll get 404, but when You enter shortened - You’ll get a 412 error - it’s the correct behavior. Note, You want to change the host string from localhost to other value that corresponds to the server, to access it from desktop machine, which most likely isn/t a server machine where Zabbix and Grafana are running

Best regards


Thank you, I had the same issue.
you solved it.

it’s really a great help

Man! You save the day! Thank´s a lot!!