Which Node version to use?

Hi,

In the documentation, I didn’t find any reference to which node version we should use. So we wrote plugins in Grafana 6.7.2 with Node 13.12.0 with success but with latest version of template generated by toolkit there is an “engines” section in package.json that seems new to me:

  "engines": {
    "node": ">=12 <13"
  }

So I wonder if we should downgrade to Node 12?

By the way I don’t find any reference to this section in the documentation:

Should I post an Issue on Github to mention it?

This is probably specified to ensure that everything work. In my case I use node 14.4 and I don’t have any issue. If someday you feel that something is wrong you could think about downgrading your node version but if it works, it works

We encourage that you try out newer versions and let us know if something breaks. Officially we support >=12 <13, but that doesn’t necessarily mean it won’t work on later versions.

We should definitely make this clearer somehow. I don’t think it belongs in the plugin.json reference docs, but I’m not sure where it should go at the moment.

Thank you for your response. In the meantime I downgraded my version just in case. But it is good to hear that it is not a strong imposed constraint.