Web.go:96 StartServer()] [E] Fail to start server: listen tcp: lookup '127.0.0.1': invalid domain name

I couldn’t find any similar errors that end “invalid domain name”, On other servers with similar configuration grafana is running fine without errors, any help would be appreciated, thanks.

2018/10/29 11:35:14 [I] Database: mysql
2018/10/29 11:35:14 [I] Migrator: Starting DB migration
2018/10/29 11:35:14 [I] Login: Ldap enabled, reading config file: /etc/grafana/ldap.toml
2018/10/29 11:35:14 [I] Plugins: Scan starting
2018/10/29 11:35:14 [I] Listen: http://‘127.0.0.1’:8808
2018/10/29 11:35:14 [web.go:96 StartServer()] [E] Fail to start server: listen tcp: lookup ‘127.0.0.1’: invalid domain name
2018/10/29 11:49:42 [I] Starting Grafana
2018/10/29 11:49:42 [I] Version: 3.0.4, Commit: v3.0.4, Build date: 2016-05-25 08:46:55 +0000 UTC
2018/10/29 11:49:42 [I] Configuration Info
Config files:
[0]: /usr/share/grafana/conf/defaults.ini
[1]: /etc/grafana/grafana.ini
Command lines overrides:
[0]: default.paths.data=/var/lib/grafana
[1]: default.paths.logs=/var/log/grafana
[2]: default.paths.plugins=/var/lib/grafana/plugins
Paths:
home: /usr/share/grafana
data: /var/lib/grafana
logs: /var/log/grafana
plugins: /var/lib/grafana/plugins

Old version - 3.0.4? Or wrong configuration, which is not supported by used version.

1 Like

Yes the issue is because of the old version 3.0.4 thats on failing server on the working servers grafana version is 5.

And removing the quotes around the loop back address: 127.0.0.1 in the grafana.ini config resolved the issue.

As suggested here: https://github.com/grafana/grafana/issues/13898