Upgraded Grafana 7 still showing old UI

Hi Team,
I have upgraded grafana from 6.7 to 7.4. our servers are running in Linux and its a rpm install, I took the backup DB and followed the instruction to completed the yum install, Upgrade completed without any error but the UI acting weird. I am still able to see the grafana UI as 6.7 and the side panel icons are not visible. Not sure what is the issue here. There is no error while restarting the grafana. Please help us.

Try to clean your browser cache.

Thanks for the immediate response.

  • I tried in multiple browser (Brave, chrome, IE, Edge, firefox)
  • Cleared cache
  • cleared all, but still no improvement.
  • even in private/incognito window the result is same.



Normally the install would have replaced the html/js/css files in your installation, there seems to be a missing part.

Can you share the detailed procedure you followed?

Good Luck

After multiple attempt, I decided to give up and chose the install method as tar ball over the Yum install. Now new version works perfectly. I copied data,plugin,grafana.ini and the ldap file to the install directory. it work fine. But still there are some missing directory we have to create like below

-> provisioning/notifiers
-> provisioning/datasources
-> provisioning/dashboards
-> provisioning/plugins
-> provisioning/plugins/sample.yaml

To overcome some error.