Unable to use piechart plugin


I have started using grafana. I currently launch it from the command line after unexpanded the tar.gz archive. I am not able to use the piechart plugin.

I tried several ways to add it :
- unexpanding the archive fetched from git
- used the grafana-cli

but each time I get in the log some errors about some a missing file ( indeed it does not exists where grafana looks at it )

INFO[01-31|19:31:54] Request Completed logger=context userId=1 orgId=1 uname=XXXXX method=GET path=/public/app/plugins/panel/grafana-piechart-panel/module status=404 remote_addr=“a.b.c.d, w.x.y.z” time_ms=78 size=27461 referer=“https://grafana.xxxxxxxxxxx/d/yxu_F0_mk/krist

I am using Grafana v5.4.3 (6539180). I have noticed that the plugin requires grafana 4.6, does it mean it is not compatible with v5 ?

If not can someone help me to troubleshot this ?

Thanks for your time.

thanks for reporting this, will test

Thanks for your time, if you need me to test something feel free to ask :slight_smile:

Hi also have the same issue :frowning:

I was starting to go crazy! Is there a fix for this?


actually I swiched first to the deb package instead of the tar gz on the official website. It worked fine then. Now I am using the docker version and it is also correct. I assume there was a compatibility issue but I did not retry since.

Sorry, I won’t be able to help more :-/