Unable to open home page

Hi,

If I launch URL http://localhost:8080 after setup ini file and started grafana-server, it is not properly opening grafana home page. attached the page that i am getting

image

Hi @krikri90,

Changing root url alone will not change the grafana login url unless it is used along with webserver or OAuth, you have to change http port also in setup ini file. Refer http port

Hi,

I have copied custom.ini file from sample.ini and changed the port to 8080. I am getting this page even after did it.

Have you built from source? What grafana version?

i just downloaded windows 64 bit binaries and extracted. Then Ran grafana-server.exe. Then i launched http://localhost:3000/

Also I changed http port to 8080 in sample.ini and launched http://localhost:8080/

But getting same page

I am using version 5.2.2

You should add a custom.ini with

[server]
http_port = 8080

i did that. There is no issue in server run and port connection. but full page is not loading. Something is blocking

When I start Grafana on Windows using port 8080 I’ll get a popup asking if I want to allow the application - I’m guessing you have sort of block somewhere? Could you please include the log when starting grafana-server?

I dont see any pop up

e[32mINFOe[0m[07-31|21:28:22] Starting Grafana e[32mloggere[0m=server e[32mversione[0m=5.2.2 e[32mcommite[0m=aeaf7b2 e[32mcompilede[0m=2018-07-25T16:47:28+0530
e[32mINFOe[0m[07-31|21:28:22] Config loaded from e[32mloggere[0m=settings e[32mfilee[0m=C:\Users\1232941\Downloads\grafana-5.2.2.windows-amd64\grafana-5.2.2/conf/defaults.ini
e[32mINFOe[0m[07-31|21:28:22] Path Home e[32mloggere[0m=settings e[32mpathe[0m=C:\Users\1232941\Downloads\grafana-5.2.2.windows-amd64\grafana-5.2.2
e[32mINFOe[0m[07-31|21:28:22] Path Data e[32mloggere[0m=settings e[32mpathe[0m=C:\Users\1232941\Downloads\grafana-5.2.2.windows-amd64\grafana-5.2.2\data
e[32mINFOe[0m[07-31|21:28:22] Path Logs e[32mloggere[0m=settings e[32mpathe[0m=C:\Users\1232941\Downloads\grafana-5.2.2.windows-amd64\grafana-5.2.2\data\log
e[32mINFOe[0m[07-31|21:28:22] Path Plugins e[32mloggere[0m=settings e[32mpathe[0m=C:\Users\1232941\Downloads\grafana-5.2.2.windows-amd64\grafana-5.2.2\data\plugins
e[32mINFOe[0m[07-31|21:28:22] Path Provisioning e[32mloggere[0m=settings e[32mpathe[0m=C:\Users\1232941\Downloads\grafana-5.2.2.windows-amd64\grafana-5.2.2\conf\provisioning
e[32mINFOe[0m[07-31|21:28:22] App mode production e[32mloggere[0m=settings
e[32mINFOe[0m[07-31|21:28:22] Initializing SqlStore e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Connecting to DB e[32mloggere[0m=sqlstore e[32mdbtypee[0m=sqlite3
e[32mINFOe[0m[07-31|21:28:22] Starting DB migration e[32mloggere[0m=migrator
e[32mINFOe[0m[07-31|21:28:22] Initializing SearchService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing PluginManager e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Starting plugin search e[32mloggere[0m=plugins
e[32mINFOe[0m[07-31|21:28:22] Initializing InternalMetricsService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing AlertingService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing HTTPServer e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing CleanUpService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing NotificationService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing ProvisioningService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing RenderingService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing TracingService e[32mloggere[0m=server
e[32mINFOe[0m[07-31|21:28:22] Initializing Stream Manager
e[32mINFOe[0m[07-31|21:28:22] HTTP Server Listen e[32mloggere[0m=http.server e[32maddresse[0m=0.0.0.0:3000 e[32mprotocole[0m=http e[32msubUrle[0m= e[32msockete[0m=
e[32mINFOe[0m[07-31|21:28:43] Request Completed e[32mloggere[0m=context e[32muserIde[0m=0 e[32morgIde[0m=0 e[32munamee[0m= e[32mmethode[0m=GET e[32mpathe[0m=/ e[32mstatuse[0m=302 e[32mremote_addre[0m=[::1] e[32mtime_mse[0m=15 e[32msizee[0m=29 e[32mreferere[0m=
e[32mINFOe[0m[07-31|21:29:51] Request Completed e[32mloggere[0m=context e[32muserIde[0m=0 e[32morgIde[0m=0 e[32munamee[0m= e[32mmethode[0m=GET e[32mpathe[0m=/ e[32mstatuse[0m=302 e[32mremote_addre[0m=127.0.0.1 e[32mtime_mse[0m=6 e[32msizee[0m=29 e[32mreferere[0m=

Seems like Grafana listen to port 3000. Please include your custom ini - are you sure you’ve named it custom.ini and put it in the conf directory?

yes I did it. But not worked

Please include your full configuration file