How to install on Windows


#1

Dear all,
On windows, you don;t expect anyone to know how to configure things after installation. It is not UNIX.

  1. I have all the files in the directory. I don’t know how to “uncomment” things in the custom file.
  2. I can run the server
  3. But when I run the client - a window blinks for a second and terminates.

HOW do I run the application, and load an excel of data into it?
PLS help.
Thanks,
Shai


#2

the client? You mean the browser?

After you start the server, what is the terminal output? Does it say it is listening on an http port? (last log output).-


#3

load excel? Grafana has no such feature, Grafana can read data from Time series databases like Graphite and Prometheus and InfluxDB. (and MySQL)


#4

Commenting in .ini files is the same for Windows and Linux. The recommended way to comment is to use a semicolon:

http://docs.grafana.org/installation/configuration/#comments-in-ini-files


#5

Hi
The last thing in the log output is “Initializing HTTP server”.
Maybe the http port is the problem? I changed to 8080 but maybe this is not our HTTP port?
Thanks a lot
Shai


#6

The default port is 3000. Did you uncomment the line in the ini file when you changed it?

This line should contain more information for example:

INFO[09-12|10:45:34] Initializing HTTP Server logger=http.server address=0.0.0.0:3010 protocol=http subUrl= socket=

In this example, the port is set to 3010.


#7

I have the same line, with port 80 (tried 8080 then 80). This is the http port here.


#8

the client - I mean grafana-cli. (don’t know what is this, thought it is a client).
Do I need to run only the server?


#9

You only need to run the server. The cli is only for installing plugins and a few other small tasks.

Start Grafana by executing grafana-server.exe, preferably from the command line.


#10

Can you show exactly the lines in your ini file for the http_port setting. It should be:

[server]
# Protocol (http, https, socket)
protocol = http
http_port = 8080

Then open http://localhost:8080 in your browser. If you are using port 80, then use http://localhost


#11

Hi
These are the lines in the ‘custom.ini’ file:

# Protocol (http, https, socket)
protocol = http

# The ip address to bind to, empty will bind to all interfaces
;http_addr =

# The http port  to use
http_port = 80

# The public facing domain name used to access grafana from a browser
;domain = localhost

# Redirect to correct domain if host header does not match domain
# Prevents DNS rebinding attacks
;enforce_domain = false

# The full public facing url you use in browser, used for redirects and emails
# If you use reverse proxy and sub path specify full url (with sub path)
root_url = http://localhost

Should I uncomment the root_url line?

When I do http://localhost I do get a login screen… :slight_smile:But I can not login, using the grafana username/password :frowning:


#12

If you get to the login screen, then Grafana is up and running.

The default username and password is admin admin. Are you getting an “Unauthorized” message or a different error? Anything in the Grafana server logs?