Unable to configure https to my grafana domain

Please avoid posting in the Grafana parent category. Whenever possible choose a subcategory.

I have ssl certs for my domain so i want secure with https for my domain after configuring grafana.ini not working as expected.
after configuring restarted grafana service it has started but unable to browse url can any one help on this please.
after updating protocol and root_url, domain my grafana.ini file

# Directory where grafana can store logs
logs = /var/log/grafana

####################################
[server]
# Protocol (http, https, h2, socket)

protocol = https

# The ip address to bind to, empty will bind to all interfaces
https_addr = 0.0.0.0

# The http port  to use
http_port = 3000

# The public facing domain name used to access grafana from a browser
domain = www.domain.com

# Redirect to correct domain if host header does not match domain
# Prevents DNS rebinding attacks
enforce_domain = false

# The full public facing url you use in browser, used for redirects and emails
# If you use reverse proxy and sub path specify full url (with sub path)
root_url = https://www.domain.com:3000/grafana

# Serve Grafana from subpath specified in `root_url` setting. By default it is set to `false` for compatibility reasons.
serve_from_sub_path = true

# https certs & key file
protocol = https
cert_file = /etc/grafana/grafana.crt
cert_key = /etc/grafana/grafana.key

THANK YOU!!

Welcome

Could you please cleanup that post so it uses medium font sizes and show only pertinent config relate to https and which part you changed in the config from what to what?

Thanks

1 Like

Hi I have mentioned only the changes i have done in grafana.ini