Tags not being applied in otsdb quries


I am trying to create an otsdb query in grafana.

I have added a tag name value pair in the query. The tag name and value showed up nicely as suggestions in tag entry fields.

But when I see the result in query inspector, tags : undefined is shown.

“queries”: [
“metric”: “10.hvac.temp_set_pt.bld1”,
“aggregator”: “avg”,
“downsample”: “10m-avg”

I have tried enabling explicit tags as well but it did not help.

I have tried this on 4.4.2 and 4.5.2 now.

Please let me know what am I missing.


You need to add a group by tag to query

I did not find group by for tags but it is there for filters.

I tried applying the same. I have attached a screenshot of the configuration that I made and the query inspector as well.

I do not see the filter being part of the query.

It was a mistake in filling up the form.

You need to click the add tag button after filling in the tag key and value.

Just like all other fields, I just filled in the value and expected it to work but it is not the case for filters and tags.

With that everything worked as expected.