Switch grafana from http to https, all grpahs are gone

i switched my running grafana from http to https.
when on https, my graphs are not shown.

do i have to do or set any special options to get them back?
when switched to https, the graphs are empty and show “no datapoints”.

any hints would be great

thank you
marko

Sounds strange. I just switched my local Grafana from http to https last week without any problems.

Are you getting any errors? You can check in the Chrome Developer Tools for frontend errors and in the Grafana server log for backend errors.

i will check grafana logs for error and report

marko

i switched to https again.
No errors in the logs.

dasboard looks lthis:

Can you check the raw query and response in the Chrome Developer Tools. Here is a guide.

more i cant find in the debugging,
i can paste the Json Model panel:

{
“aliasColors”: {},
“bars”: false,
“datasource”: “PAC BACKUP”,
“description”: “cpu load zabbix server”,
“fill”: 1,
“id”: 1,
“legend”: {
“avg”: false,
“current”: false,
“max”: false,
“min”: false,
“show”: true,
“total”: false,
“values”: false
},
“lines”: true,
“linewidth”: 1,
“links”: [],
“nullPointMode”: “null”,
“percentage”: false,
“pointradius”: 5,
“points”: false,
“renderer”: “flot”,
“seriesOverrides”: [],
“span”: 6,
“stack”: false,
“steppedLine”: false,
“targets”: [
{
“application”: {
“filter”: “CPU”
},
“functions”: [],
“group”: {
“filter”: “Zabbix servers”
},
“host”: {
“filter”: “Zabbix server”
},
“item”: {
“filter”: “Processor load (1 min average per core)”
},
“mode”: 0,
“options”: {
“showDisabledItems”: false
},
“refId”: “A”
},
{
“application”: {
“filter”: “CPU”
},
“functions”: [],
“group”: {
“filter”: “Zabbix servers”
},
“host”: {
“filter”: “Zabbix server”
},
“item”: {
“filter”: “Processor load (5 min average per core)”
},
“mode”: 0,
“options”: {
“showDisabledItems”: false
},
“refId”: “B”
},
{
“application”: {
“filter”: “CPU”
},
“functions”: [],
“group”: {
“filter”: “Zabbix servers”
},
“host”: {
“filter”: “Zabbix server”
},
“item”: {
“filter”: “Processor load (15 min average per core)”
},
“mode”: 0,
“options”: {
“showDisabledItems”: false
},
“refId”: “C”
}
],
“thresholds”: [],
“timeFrom”: null,
“timeShift”: null,
“title”: “CPU Load”,
“tooltip”: {
“shared”: true,
“sort”: 0,
“value_type”: “individual”
},
“transparent”: true,
“type”: “graph”,
“xaxis”: {
“mode”: “time”,
“name”: null,
“show”: true,
“values”: []
},
“yaxes”: [
{
“format”: “short”,
“label”: null,
“logBase”: 1,
“max”: null,
“min”: null,
“show”: true
},
{
“format”: “short”,
“label”: null,
“logBase”: 1,
“max”: null,
“min”: null,
“show”: false
}
]
}

So, the api_jsonrpc.php is shown in red, thats all.

What is your datasource config? Direct or proxy?

Can you click on the red line and investigate the error? What error message is there in js console?

hello,
data source config “direct”.

red again and following is shown:

If you use direct you probably need more specific CORS headers added by your datasource to allow access from grafana, using https wildcard origins are now allowed by browsers

You are trying to reach http site (Zabbix API) from the https site (Grafana), which is by default blocked by your browser. Switch your Zabbix to https as well or try to use proxy access to the Zabbix (configure it in Zabbix datasource settings).

jangaraj,
this works, switching datasource to proxy - and it works again.

thanks to all for help

kind regards

marko