Support grafana armhf

Hi There,

Today i tried to install Grafana on my routher in a virtual lxc environment. The container runs a default Ubuntu 16.04 base install. After following these instructions.
I found out that the latest available version for armhf architecture is stuck at version 2.6.0, wich is pretty old and not in the grafana repository.

apt-cache policy grafana
grafana:
Installed: (none)
Candidate: 2.6.0+dfsg-1
Version table:
2.6.0+dfsg-1 500
500 http://ports.ubuntu.com/ubuntu-ports xenial/universe armhf Packages

Are there plans to add the armhf architecture to the official repository?
Which installation method do you recommend to get the latest installed?

Best Regards,

John

Hi,

Yes, we really would like to improve our whole build pipeline this year and included in this should be arm support.

I know that there are an unofficial repository that builds arm releases at least for raspberry pi’s here. Maybe you can use that for building a Grafana version for your specific arm architecture/device.

Marcus

Thanks, I installed a .deb from their repository and seems to work fine!

1 Like