What is the update procedure for Grafana on Raspberry Pi?


Pi4 currently running Grafana v 9.2.3

pi@pi-4:~ $ grafana-cli -v Grafana CLI version 9.2.3

What is the recommended way to update Grafana to latest version?

Thank you.

hi @Richard238 :wave:

In theory, the upgrade steps would depend on the distribution you installed on your raspberry pi. If you followed this tutorial,, and your distro is Raspbian, you can just run a apt upgrade. Debian package manager commands should work for you. These commands are use for upgrading Grafana via apt package manager.

Goodness knows what I’ve done, but config says I’ve gone back a few versions:

 v7.0.0 (aee1438ff2)

Tried again, noticed this:

dpkg: error processing archive grafana-enterprise_9.4.7_arm64.deb (--install):
 package architecture (arm64) does not match system (armhf)

Where’s the armhf latest version download?

Also, WRT the Pi Install instructions:

pi@pi-4:~ $ wget -q -O - https://packages.grafana.com/gpg.key | sudo apt-key add -
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
pi@pi-4:~ $ 

what is your system architecture 32 or 64?

are you using ARMv6 or ARMv7?

If you are looking for ARM installs, this is page

It’s a Pi4 running Bullseye:

pi@pi-4:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"

Spec says it’s ARM v8

Tried ARM v7

pi@pi-4:~ $ sudo dpkg -i grafana-enterprise_9.4.7_armhf.deb
dpkg: regarding grafana-enterprise_9.4.7_armhf.deb containing grafana-enterprise:
 grafana-enterprise conflicts with grafana
  grafana (version 9.2.3) is present and installed.

dpkg: error processing archive grafana-enterprise_9.4.7_armhf.deb (--install):
 conflicting packages - not installing grafana-enterprise
Errors were encountered while processing:

OK, back up and running on

[v9.2.3 (ec9c2ed029)]

Would very much like to move on to 9.4.7, but need working how-to guide for the Pi ARM v8, please.

Thank you


Would that be v 9.2.3 OSS or Enterprise? If Enterprise do you have a license?

Check this out here

No idea, how do I find out? (I do not have an enterprise license.)

you should be able to see it when you open grafana and click on bottom left help icon

for version

and also check here


Anyways it does not matter cause you will need to install OSS.

  1. Find and stop currently running grafana
  2. rename folder where grafana is installed to whatever_it_is_now to whatever_it_is_now_old
  3. Install new one
sudo apt-get install -y adduser libfontconfig1 (you might not need to do this)
wget https://dl.grafana.com/oss/release/grafana-rpi_9.4.7_armhf.deb
sudo dpkg -i grafana-rpi_9.4.7_armhf.deb
  1. Copy the grafana.db and default.ini (if one exists for rpi) files from their respective folder in whatever_it_is_now_old to their respective folder in the newly installed folder.
  2. Start grafana in new folder (however you do that in rpi) = Page not found, green graph…

[v9.2.3 (ec9c2ed029)]

that doesn’t matter anyways, since you do not have a license. just proceed with upgrade.

1 Like

I tried a grafana update again recently:

sudo apt install grafana
grafana is already  the newest version (9.2.3)

How do I get it to the very latest version?
The Pi4 host is fully up to date.

Thank you.

Hi! have you tried

sudo apt-get update
sudo apt-get upgrade

instead ?