Suddenly "no data points"

I have several sensors connected to a Raspberry Pi that have been producing data that’s stored in InfluxDB and displayed by Grafana. About a day ago I unplugged a USB wifi dongle from the unit, which should not have interfered with data taking but did disconnect with the Grafana server on another device. When I replaced the dongle and rebooted, all data sources started displaying on Grafana except for one, and for that I get the banner “no data points.” Since I run the data collections via applications with systemctl, I can tell that this particular sensor is taking data and writing to InfluxDB.

I have rebooted both the data taking Raspberry Pi and the unit that runs Grafana. I have checked to be sure that all data-taking apps are actually running. Everything looks except that Grafana thinks there is no data - but there is.

I have no idea what caused this, nor how to track down the problem and solve it.

SOLVED: two databases somehow got confused and interchanged.