Bad Gateway connecting to influxdb


I run Grafana v7.3.7 and influxdb in a Raspberrypi using Portainer. Grafana worked fine for several months until yesterday
I haven’t changed anything. Just Grafana stopped showing Diagrams with the message No Data.

I’ve restarted the Raspberry and both Grafana und Influxdb containers from Portainer.

I’ve tried to access localy (connecting via VNC and running Grafana from the Raspberry’s browser) but the problem remains.

One last thing.
The connection with influxdb is not completely broken because, for a few secons, the data have apeared on screen. That hat happen twice.

As I’m not an expert in computers and Grafana worked perfectly until yesterday evening, I don’t know what to do or how to solve this issue.

The influxdb logs

ts=2022-10-12T17:01:44.634160Z lvl=info msg=“Opened shard” log_id=0dVI9tZ0000 service=store trace_id=0dVI9ty0000 op_name=tsdb_open index_version=inmem path=/var/lib/influxdb/data/telegraf/autogen/179 duration=1.031ms,

Grafana logs
EROR[10-12|16:50:11] Data proxy error logger=data-proxy-log userId=1 orgId=1 uname=admin path=/api/datasources/proxy/3/query remote_addr= referer=“” error=“http: proxy error: dial tcp connect: connection refused”


Finally the problem seems solved … but I did nothing. After a couple of days, Grafana shows the data again.

I supose it was a kind of Raspberry’s faint.