Stat panel fractional units. It worked in the previous version

I’m using grafana 8.3.3 on a RPI running raspian.
I’m moving to grafana 9.2.2 on an odroid-N2+ running ubuntu 20.04

I have migrated a “weather wall” dashboard from my old system to the new, which resulted in a newer version of Stat Panel.
For my “rain last hour”, my query is:
SELECT spread(“rain”) FROM “outside” WHERE time > now() - 1h
I have the units set to mm and when the result is a whole number, the panel displays as expected (i.e 1mm, 5mm, etc).
However when the result of the query is fractional; e.g. 0.6, the panel displays 600um. Using the old version it displayed 0.6mm which is what I expect.
All panel settings are identical between old and new.
How do I display a result of 0.6 as 0.6mm and not 600um??

P.S. I tried to upload a screen grab but I kept getting an error.

Try to define custom non SI unit Configure standard options | Grafana documentation and/or override it as String units.

I have also noticed this behavior recently. Below is an example…

Also found an open Github issue where @mattabrams was involved, so maybe he can provide an update here.

I did read that and to quote the doco:

To select a custom unit enter the unit and select the last Custom: xxx option in the dropdown.

My “unit” is Distance and there is no “Custom” at the end of that dropdown.

If I select “Misc->Number”, I get the 0.6 but no suffix of mm (which is what I got under the old version).
I’d be grateful for clarification on this and the documentation recommendations.
I find the “official” documentation extremely hard to follow. Either the documentation has not kept up or there is “assumed knowledge” which I clearly lack as a new comer.

I managed to upload my images to the open github issue.
I don’t understand why I can’t do it here.

It is a dropdown, but you can write there. Click there and use keyboard to write own custom unit.

@helian Short video clip here: Date in table column in Grafana dashboard instead of date and time - #7 by grant2

Can you tell me exactly what I need to enter please??
I am obviously missing something here.
When I specify mm as a “Unit of measure”, that is EXACTLY what I want; fractional or not.
I can not see a situation where the current implementation would be useful.

Never mind; I’ve figured it out.
To help others, by entering “suffix: mm” in the “unit” field gave me the result I wanted (i.e like it was in the old version).

Why I have to do this is beyond me since the result of the database query is in mm.

To be clear, the actual “Unit of measure” here IS NOT millimetre; it is metre. The ‘milli’ prefix is a multiplier, meaning one thousandth of a metre.

So, if I specify mm as a “Unit of measure”, this is EXACTLY how I want it displayed; fractional or not.
Same goes for Kilogram (Kg). If I want weights specified in grams, that is what I would select.

My micrometers, dial gauges and vernier caliper specify their resolution as 0.02mm; NOT 20um.

You may as well get rid of all the options in the “unit” drop down and just have the suffix: command to specify the units.

Adding new features should not break old ones. I can just imagine the frustration people would feel having to spend hours modifying their existing dashboards after upgrading, because of someone’s thought bubble.