Set displayed unit value explicitly (MWh instead of GWh)

I am displaying energy data on a stats panel. The raw data is in Wh. I used the ‘Standard Option’ → ‘Unit’ to set it to Wh and since the value is pretty big, it will show ‘3.5 GWh’. Now, I want to set the unit explicitly to MWh to get something like ‘3,562.2 MWh’. I researched on setting the unit value explicitly, but didn’t found anything. Is there a solution to this Problem? I could increase the number of decimals, but it would be mostly a workaround, not a solution.
Thanks in advance!
Grafana v. 10.2.3

1 Like

Thanks! I see this feature is new in v. 10.3. I will update Grafana and then use it.

The auto scaling toggle switch is not present anymore in Grafana 10.4.
Also, in the official docs for Grafana 10.3, the feature “scale units” is mentioned. However, it is not mentioned anymore in the docs for Grafana 10.4.

Correct. It was implemented and then it was removed: FieldOptions: Revert scalable unit option as we already support this via custom prefix/suffixes by torkelo · Pull Request #81893 · grafana/grafana · GitHub

@ jangaraj Thank you for the clarification. I tried the solution with custom suffixes and it seems to work fine.