Incorrect scale values

Since the last update, my scale is only given in MWh although the values are in KW. Does anyone have any ideas? It fits with my other overviews

You can add some decimals via standard options, e.g. 2 so it will be 2.XX MW.
You can’t disable scaling (it was possible for a moment, but it was removed: FieldOptions: Revert scalable unit option as we already support this via custom prefix/suffixes by torkelo · Pull Request #81893 · grafana/grafana · GitHub), so if you don’t want to scale explicitly, then define custom suffix (kWh) via the standard unit option.